Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Heat Pump broken and just sits there

  1. Back To Top    #1

    Join Date
    Aug 2010
    Location
    Atlanta, GA
    Posts
    39

    Heat Pump broken and just sits there

    I bought a house and the pool is great but there is a AquaCal big sqaure black heat pump that looks like on the inside the compressor is cracked (I guess it froze and broke)? Anyway, has anyone had these repaired? If not have you removed it and with what? The thing is huge! Any ideas would be appreciated. My parents had a pool an the pool heater there was also broken. I haven't seen a working one lol! This one looks less than 7 years old but it's broken.

    Tom
    40x20 Vinyl Inground (27,000 gal). SWG with Pentair 48 DE Filter.
    Also have a broken Polaris pump with no polaris and a broken AquaCal Heat Pump...inherited from last owner.

  2. Back To Top    #2

    Join Date
    Dec 2009
    Location
    Central Massachusetts
    Posts
    2,690

    Re: Heat Pump broken and just sits there

    Are you sure its the compressor? The compressor itself doesnt get water in it, only refrigerant. The heat exchanger on the other hand can freeze and crack if the water isnt drained properly. Pictures would help
    14,000 gallon IG, Vinyl. Hayward 3/4 hp superpump, Penatair IC40 SWCG, Pentair automation, Hayward sand filter, Aqua Comfort heat pump, Hayward 400k Lo-Nox LP heater.

  3. Back To Top    #3

    Join Date
    Aug 2010
    Location
    Atlanta, GA
    Posts
    39

    Re: Heat Pump broken and just sits there

    Nope I wasn't, it looks to be the heat exchanger and I called AquaCal support to see what they would say (he said heat exchanger and I remember a pool guy looking and saying the same). He also said it's a $1500 repair but that's not too bad considering new pumps are 3-4K! I think I'm going to wait until the weather cools down and see if we want to do it.

    Tom
    40x20 Vinyl Inground (27,000 gal). SWG with Pentair 48 DE Filter.
    Also have a broken Polaris pump with no polaris and a broken AquaCal Heat Pump...inherited from last owner.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •