Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 12 of 12

Thread: SpeedStir bar not spinning.

  1. Back To Top    #1
    TimS's Avatar
    Join Date
    Sep 2009
    Location
    Central Missouri
    Posts
    214

    SpeedStir bar not spinning.

    I bought the Taylor SpeedStir earlier this year, and it's been really handy for testing. I've been happy with it.

    But... (of course there's a "but") lately, the bar hasn't really been spinning in the cylinder. Instead, it sort of vibrates, and makes about 10 revolutions per minute, compared to the high speed it had when it was new. It still mixes, but not nearly as quickly as when it was new. I'm using the mixing vial that came with it, and the vial is clean. I don't see any damage that could account for this.

    Has anyone else experienced this? Is it simply time to buy a new bar?

    Has anyone opened one up to determine how it works? Does it have a motor that physically spins a magnet, or does it alternate the fields through a coil to "spin" the field itself?
    24' AG Round (vinyl replaced 0909) - 13500 gal - Sand Dollar Filter (150lb) - Dynamo DYNII-N1-1 1HP - Hayward HP380 Heat Pump - TF-100.
    Central Missouri

    Before I speak, I have something important to say.

  2. Back To Top    #2

    Join Date
    May 2009
    Location
    Dallas, TX
    Posts
    781

    Re: SpeedStir bar not spinning.

    Try fresh batteries...
    20K gal IG plaster pool, Manually chlorinated with 6% bleach, 1.5 HP Sta-Rite Dura-Glas II pump, Pentair FNS Plus 48 DE filter, Polaris 280

  3. Back To Top    #3

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: SpeedStir bar not spinning.

    Are the batteries fresh?
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  4. Back To Top    #4
    Guest

    Re: SpeedStir bar not spinning.

    X3 on the batteries!

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: SpeedStir bar not spinning.

    X4 for batteries.

    It's not actually a motor as you're thinking. It's three separate coils that are energized in sequence to attract the bar from one to the next. So in effect it's a motor just not in the conventional sense.

    Check your bar too. It should be a fairly strong magnet. If a metal object won't pick it up you need a new bar. Be sure to buy a smooth bar not a raised ring one. Ebay has them so does Houston Scientific.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6

    Join Date
    May 2010
    Location
    SW Georgia
    Posts
    298

    Re: SpeedStir bar not spinning.

    Mine is doing the same thing and I figured it was the batteries. You can turn it on first and then drop in the bar and this tends to work.
    35K IG Vinyl 20 x 40 self built pool, Hayward Pro Series High-Rate Sand Filter 31" 98gal/min, Hayward TriStar 1.85hp, Hayward 400btu heater, BBB method w/Hypo, Jazz light w/matching fiber optic rope lighting around coping w/syncronized color wheels. Concrete Paver deck.

  7. Back To Top    #7
    TimS's Avatar
    Join Date
    Sep 2009
    Location
    Central Missouri
    Posts
    214

    Re: SpeedStir bar not spinning.

    Well that was pretty stooopid! Naturally it would be the batteries. I really should have thought to check that first. Oh, well.

    Replaced the batteries, and it's back to it's old self, complete with spinning the mixing tube on the base.

    Quote Originally Posted by Bama Rambler
    It's not actually a motor as you're thinking. It's three separate coils that are energized in sequence to attract the bar from one to the next. So in effect it's a motor just not in the conventional sense.
    I expected it to be two coils instead of three, but that's basically what I thought it might be. Probably more economical and durable to build it that way, instead of with a motor.

    Quote Originally Posted by Bama Rambler
    Ebay has them so does Houston Scientific.
    Taylor wants about $10 each for them. EBay is closer to $4.50.
    24' AG Round (vinyl replaced 0909) - 13500 gal - Sand Dollar Filter (150lb) - Dynamo DYNII-N1-1 1HP - Hayward HP380 Heat Pump - TF-100.
    Central Missouri

    Before I speak, I have something important to say.

  8. Back To Top    #8
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: SpeedStir bar not spinning.

    Quote Originally Posted by TimS
    Quote Originally Posted by Bama Rambler
    Ebay has them so does Houston Scientific.
    Taylor wants about $10 each for them. EBay is closer to $4.50.
    I received 4 stir bars today. I ordered them off ebay from some homebrewer supply in Michigan. $17.71 via paypal, delivered.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  9. Back To Top    #9
    DaveNJ's Avatar
    Join Date
    May 2007
    Location
    Toms River, NJ
    Posts
    520

    Re: SpeedStir bar not spinning.

    Had gotten my SpeedStir 3/10, and it didn't work. The stir bar just vibrated. I put a small button magnet in the vial and jumped all around, suggested the stir bar was bad. Customer service sent a new base unit and having me replace the batteries a couple of times. The new base unit did the same thing. Finally sent new stir bars and it works fine. Just had to go through their process.
    IG 18x36 oval vinyl, Spill over spa, Northstar 2hp-2spd, 2.5" piping, S310T 500lb Sand filter, 400k gas heater, AutoPilot SWCG
    http://www.tftestkits.net/

  10. Back To Top    #10
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: SpeedStir bar not spinning.

    The first one I got had a bad stir bar. Maybe we should let Taylor know exactly what the problem was so they can send a magnet first.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  11. Back To Top    #11
    DaveNJ's Avatar
    Join Date
    May 2007
    Location
    Toms River, NJ
    Posts
    520

    Re: SpeedStir bar not spinning

    Customer service said they had no complaints or inquiries on stir bar.
    IG 18x36 oval vinyl, Spill over spa, Northstar 2hp-2spd, 2.5" piping, S310T 500lb Sand filter, 400k gas heater, AutoPilot SWCG
    http://www.tftestkits.net/

  12. Back To Top    #12

    Join Date
    Aug 2010
    Location
    Columbia, SC
    Posts
    96

    Re: SpeedStir bar not spinning.

    I was looking online to find a new bar. Mine had been doing the vibrate thing for a couple of months. Put fresh batteries in today and voila!!! like new!
    20K Gal Blue Plaster IG with rock waterfall, Beach Entry, Hayward Goldline Pro Logic controller and SWG,
    Sta-Rite System 3 S7M400 cartridge filter, 1-1/2 HP pump, Energy Therm Heat Pump, Nexxus Savi LED lighting

    500 Gal Dynasty Miramax Fiberglass Cinema Spa

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •