Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: polaris pop up trouble

  1. Back To Top    #1

    polaris pop up trouble

    i have a two year old pool with a polaris pop up in floor cleaning system. the pop ups have stopped working all together. the water pressure builds up in the actuator valve but none of the pop ups come up. i have taken it apart at least ten time and everything looks correct. what can i do?
    24'x52" AGP (13,500 Gallons)
    Aqua-View 20" High Rate Sand Filter
    1.5 HP Powerline Pump

  2. Back To Top    #2

    Re: polaris pop up trouble

    I have a paramount pcc2000 system that may be similar to yours. Do you have a shut off for the valve assy? (turns off the operation of the valve system operation) Sounds like you have pump pressure to the valve assy. check the pop ups for obstructions. If all ok, check flow on each circuit from valve housing to pop up. If ok then I would suspect the valve assy. The valve and the popups are the only mechanical items in the system. (besides the pump) the rest is pipe. In my system. JM2C
    16K gallon, Pebble tec, beach entry. Two 1 hp Pentair Whisperflos. One for Paramount MDX2 main drain, Paramount debris canister, and Pentair CCP 520 filter. One for skimmer w/sock and Paramount PCC2000 in floor cleaner. 3/4 hp Pentair Pinnacle for waterfall. Fiberstars fiber optic pool lighting. Aqua-Logic AQL-P-4 control panel with wired remote in the house. SWCG system that is not used. Ultra-Pure Ozonator that is not used.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts