Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 16 of 16

Thread: Goldline Aqualogic PS-4

  1. Back To Top    #1

    Goldline Aqualogic PS-4

    Hello...
    Keep getting a message on display...CHECK SYSTEM LOW VOLTS.
    Cert. dealer here yesterday....T-15 cell works good....
    Circuit board....transformer output readings good
    Solar system no issues

    HELP! BAFFLED! NO ANSWERS! HELP!

  2. Back To Top    #2

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Goldline Aqualogic PS-4

    Could be:

    High Salt
    Failing bridge rectifier
    Corrosion on the connections
    Failing transformer leg


    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  3. Back To Top    #3

    Re: Goldline Aqualogic PS-4

    Salts are are 3000 ppm

    Appreciate the response.

    Wish there were more like you in Las Vegas...refering to your quote under your sig....

    Here in Las Vegas it still is like the wild wild west.....

  4. Back To Top    #4

    Brentr's Avatar
    Join Date
    Oct 2009
    Location
    Jacksonville, FL
    Posts
    1,615

    Re: Goldline Aqualogic PS-4

    Welcome to TFP
    I feel your pain You need to move to Florida
    6,000 gal, IG free form,Beach Series Antigua by Marbletite Pebble finish,Sheer Descent, IG Fountain, Dolphin / Mermaid Statues,Dura- Glas 1.5hp pump,Hayward Pro-grid DE4820, Aqua Rite SWG with T-Cell 15,Heat Siphon Heat Pump DX 5.0 109,000 btu, Pool Cage, 1800sq ft Tremron Estate Pavers,Aquatherm Ecosun Solar Panels 192 sq ft with GL-235 Controller,Pentair IntelliBrite, Apollo Magnetic Stirrer Our New Poolbuild, Jacksonville, FL yr 2009 Solar install Outdoor kitchen upgrade

  5. Back To Top    #5

    Re: Goldline Aqualogic PS-4

    Thanks all for comments....

    NOW....

    What do I do first?

    Main board replacement
    or
    Replace T-15 cell

    Either way I know $$$$$$$$$ are involved.....
    I am just a disabled vet but feedback is appreciated.

    To many cowboys in Vegas ...rob you blind and smile as they do it!

  6. Back To Top    #6

    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,160

    Re: Goldline Aqualogic PS-4

    Welcome to TFP!!

    Find someone who knows how to use a digital voltmeter and then call Goldline's support #. They'll make you wait ~ 30 min on hold but then will walk you through what to test to find out which part is bad. Short of being able to do that, I'd start with the rectifiers
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  7. Back To Top    #7

    Re: Goldline Aqualogic PS-4

    Pumps are running....

    Now no reading for salt at all....

    If pumps are running, everything working except no salt numbers...suspect the t-15 cell did die.

    Feedback please.

    Thanks for the patience all.


  8. Back To Top    #8

    Re: Goldline Aqualogic PS-4

    maybe just shut ever thing down..hook a hose up to fire hydrant and just enjoy that..............

  9. Back To Top    #9
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,478

    Re: Goldline Aqualogic PS-4

    First, make sure the cell is clean.

    Then go to the diagnostic menu and click to the first entry. It should read the volts and amps of the cell. Report back.

    If the cell were failing, current should drop but not voltage. Too much salt would tend to drop the voltage some but current will rise and then you should get a high salt warning and not a low voltage warning.

    The PS-4 is notorious for failing in the power supply circuit, specifically a solder joint on the board which burns out. This can be diagnosed/fixed with this proceedure.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  10. Back To Top    #10

    Re: Goldline Aqualogic PS-4

    Reporting back...

    Cell is 100 per cent clean!
    When to Diagnostic Menu....Readings were all ZERO except air temp 85 degrees....

    Standing by....

  11. Back To Top    #11
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,478

    Re: Goldline Aqualogic PS-4

    Did you press the "+" button while reading the voltage/amps to start the cycle over? Try that first. If it is still 0 readings then it sounds like a board failure which is explained in the link I posted above. Look at the proceedure and see if you are comfortable taking care of this yourself and make sure you turn off all the breakers to the panel before proceeding.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  12. Back To Top    #12

    Re: Goldline Aqualogic PS-4

    I want to THANK EVERYONE FOR THE ASSISTANCE...

    BOTTOM LINE.....

    Will skip all my medications for a month to save up for a new motherboard. Did all the tests as recommended and looks like a board failure.

    I surely will tip my hat off to each and one everyone on this board.

  13. Back To Top    #13
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,478

    Re: Goldline Aqualogic PS-4

    Did you check to see if it is the solder joint? You may be able to fix the board instead of replacing it.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  14. Back To Top    #14

    Re: Goldline Aqualogic PS-4

    Did the fix as recommended...NO GO! New board will come with 1 year warranty.

  15. Back To Top    #15

    Re: Goldline Aqualogic PS-4

    Looks like I've run into the same problem, no voltage, no amps, and only a TCell temperature reading. What would be causing the motherboards to be going bad? My system is only 3 years old.

    -Terry

  16. Back To Top    #16
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,334

    Re: Goldline Aqualogic PS-4

    A lot of things can cuase the boards to fail. Bad design or manufacture is the case with the solder joints. Power surges are a major culprit in most electronic part failures. Even if you don't know there was a surge or spike it takes a toll on the components.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •