Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: pump problem

  1. Back To Top    #1

    pump problem

    New user here.. first year set up first of May this year.. water from city system got balanced wonderful clear good PH and CL all the time ..noticed that i never got a reading on the PSI gauge new filter not much debris ever in the pool 3 months in all of the sudden this week after vacuuming a lot of pine little things off the bottom almost no pressure out of the return so i removed the filter hosed off well reinstalled no better...today I replaced the gauge no pressure reading removed the filter ran pump no increased flow from the return even without the filter...have i clogged my pump? broke my pump have hard plumbing not hoses there is more flow on high speed but it just seems reduced where do I start to check for clogs cut off valves inside the pump don't really know what it looks like in there(always wanted to though )
    Hate to replace filter this late in season but will water has been wonderful with BBB any suggestions from you pros thanks ahead of time Pro clean filter 2HP 2speed pump the reduced flow concerns me especially since the PSI never moved even with replaced how is this reading generated any way psi in the tank atmosphere?
    GPMIDWAY 18X33 AGP 2HP CARTRIDGE 2 SPEED
    WINSTON SALEM NC

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: pump problem

    I think I get what you're talking about.

    If you have no pressure with a new gauge and no filter element, you aren't pumping anything. Either there's a clog somewhere in the suction side (a clog on the return would cause high pressure) or you just plain aren't pumping.

    First question: does the pump sound the same as it did last week? There's always a chance you broke the impeller or something.

    Since the problem happened after vacuuming up a lot of debris, I'm leaning towards a clog. Hopefully you have some way to access the pump end of the suction line. Through the strainer basket, maybe there's a coupler you can undo, something. Try blasting out a clog with a drain king.


    Next step is to kill all the power then poke around the impeller of your pump. Hopefully you can get a finger up there. See if it's clogged or if it spins with the motor off.

    Let us know how it goes and we'll see if you need any more ideas
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3

    Re: pump problem

    Thanks much I will try does the pump sound different ? I don't think so so if the clog were past the pump it would raise psi ? The high speed does increase the flow.. other than the impellers not much to go wrong with a pump i guess are clogs common in pumps guess i need to get a sock I was sort of uncomfortable sucking up all that trash have only had to vacuum infrequently
    GPMIDWAY 18X33 AGP 2HP CARTRIDGE 2 SPEED
    WINSTON SALEM NC

  4. Back To Top    #4

    Re: pump problem

    Richard 320 it is still pumping because I still have flow from the return now I can totally stop the flow with my hand on low speed not possible before will get a drain king tomorrow I've never seen either gauge read anything but 0 thanks again
    GPMIDWAY 18X33 AGP 2HP CARTRIDGE 2 SPEED
    WINSTON SALEM NC

  5. Back To Top    #5

    Re: pump problem

    Well it turns out that the real problem was that both times I cleaned the filter I forgot to bleed the air out of the filter Now I have full flow again hallelujah Problem solved.Apparently that will really reduce flow
    GPMIDWAY 18X33 AGP 2HP CARTRIDGE 2 SPEED
    WINSTON SALEM NC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •