Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Broken Fiberstars

  1. Back To Top    #1

    Join Date
    May 2010
    SW Georgia

    Broken Fiberstars

    The other night I noticed my Fiberstars 6004as illuminator smoking. This smoke had a smell of electrical objects being burned. Once I saw this I turned it off waited about 1/2 an hour and turned it back on and it worked. The next day I took the top enclosure off and look for any possible damage and discovered that a silver metal flask looking object had black foamy crud uzing out of it. I figure this was the problem. I emailed Fiberstars to see if I could get a replacement part to fix the unit and they told me that the whole unit would have to be replaced. They made no mention of their warrantee. The tech person indicated that UL required that they had to replace these parts and I guess they do not do this since they told me the unit had to be replaced. The Tech person indicated that the part I was needing was a ballast and igniter. I have done research and can buy Metal Halide Ballast and igniters for around 50 dollars. Has anyone had a similar problem and how did you handle it??? If I have to purchase a new unit why would I not try some other make that may last longer???
    35K IG Vinyl 20 x 40 self built pool, Hayward Pro Series High-Rate Sand Filter 31" 98gal/min, Hayward TriStar 1.85hp, Hayward 400btu heater, BBB method w/Hypo, Jazz light w/matching fiber optic rope lighting around coping w/syncronized color wheels. Concrete Paver deck.

  2. Back To Top    #2

    Re: Broken Fiberstars

    I would tell them if it was a recall I expect them to cover the cost...worst thing that can happen is they don't and at least you tried.
    25k gal vinyl AquaRite T-15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts