Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aqua comfort

  1. Back To Top    #1
    spiazza's Avatar
    Join Date
    Jun 2009
    Berkeley Heights, NJ

    Aqua comfort

    When I power on my aqua comfort heater i receive a flashing "Po" error code.

    The manual states this error means open connection on water temperature sensor or bad sensor.

    I opened up the unit and examined the sensor and the cable leading up to the control panel. It looked clean and not cut. Cleanly connected to terminal.

    Is a professional necessary to correct this issue or should i try to get a replacement sensor from the manufacturer and install myself?

    Does anyone have experience with this type of heater?
    My Pool Stats
    IG Pool - 21,000 Gallon - Vinyl Liner
    Hayward 1.5HP Super Pump EE; Hayward DE Filter; Goldline SWG
    32' x 16', 8' deep at the deep end, about 3' shallow end

  2. Back To Top    #2

    Join Date
    Apr 2007
    Ft Lauderdale, Florida

    Re: Aqua comfort

    Aquacomfort is a marketing group with private label products. The exact model of aquacomfort heat pump is based on how old it is. They have gone through several different manufacturers over the past 10 years.

    Heat pumps usually come with good warranties though. I would contact them first.

    If its out of warranty, usually you can measure the resistance on the sensor wires to see if it is the sensor or not. The manufacturer should be able to tell you the acceptable resistance range for a good sensor. If its bad, its easy enough for you to replace. PLEASE use all safe guards to prevent electrocution and turn the circuit breaker to the heat pump OFF.
    Sean Assam -
    National Accounts and Commercial Products Manager
    AquaCal Heat Pumps
    AutoPilot Salt Chlorine Generators

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts