Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 6 of 6

Thread: need help - replace a part for Polaris Booster Pump pb4

  1. #1
    Senior Member
    Join Date
    Jul 2009
    Location
    Massachusetts
    Posts
    140

    need help - replace a part for Polaris Booster Pump pb4

    Hi - I'm hoping someone who is experienced with the Polaris PB4 pump can help me out. Shortly after we moved in in August 2009, the hose connection at the top of the polaris started to leak. We did the idiot-thing and duct taped it, which seemed to do OK at the end of the season. When I tried to use it this season, it was leaking through the duct tape, so of course, I just added more duct tape. Then, while we were out, the hose disconnected from the booster pump and we lost about 5 inches of water in the pool. I'm trying to buy the replacement part, but in looking at the parts we have and the replacement part diagram http://www.epoolshop.com/polaris_boo...variation=4199 it seems that we have non-standard parts. I was just about to buy part #20 (P133), but I'm worried because the part I have doesn't look like the part in the picture. And the part in the picture is only compatible with the Polaris Hose, which I'm not sure I have either. What really baffles me the most is that I have no idea how our hose connects to the booster pump. There is nothing that appears to grip the hose and keep it attached to the pump (see pic #03 and #04) - could sealant really have kept a high-pressure hose attached to the connector? And the same connectors are used on the end of the pump too (which haven't busted yet). Can someone please help me understand what I need to do? I'm trying to cut costs by fixing this ourselves and avoid calling a pool guy - but I've been trying to figure this out for a few weeks.
    Attached Images Attached Images
    27,500 gallon gunite pool with waterfall (built 2002 - owner as of 2009), Aerotemp / Aquacal heat pump AT12000-A, Hayward DE4800 Filter, AOS UST1202 Motor, Hydro-King T104P201 Timer, Meyco pool cover, Pentair Model 320 Auto Chlorine Feeder. Located in Massachusetts.

  2. #2
    Senior Member In the Industry

    Join Date
    Aug 2007
    Location
    near the swamp
    Posts
    788

    Re: need help - replace a part for Polaris Booster Pump pb4

    You need part p133, what you have there is a 3/4" pvc MPT fitting which is designed for the pipe/hose to be glued in.

  3. #3
    Senior Member
    Join Date
    Jul 2009
    Location
    Massachusetts
    Posts
    140

    Re: need help - replace a part for Polaris Booster Pump pb4

    wow, i'm so glad to see a response - this issue has been haunting me for so long and I held off posting b/c I feel like I always ask silly questions..

    I read from the PB4 manual that the Softubeâ„¢ quick connect is designed to work with the Polaris white reinforced hose (part #P19) only. Can you tell from my pic whether I have #P19? I'd hate to buy P133 and then find out I need to buy a new hose too.. There's nothing on the tube that says P19.

    Also, any ideas why they would use a glue connector instead of P133? Should I try to just glue it back, if so, what kind of glue should I use? Given the force of water, I really am surprised that glue could keep this together..

    Thanks again!!
    Patty
    27,500 gallon gunite pool with waterfall (built 2002 - owner as of 2009), Aerotemp / Aquacal heat pump AT12000-A, Hayward DE4800 Filter, AOS UST1202 Motor, Hydro-King T104P201 Timer, Meyco pool cover, Pentair Model 320 Auto Chlorine Feeder. Located in Massachusetts.

  4. #4
    Senior Member In the Industry

    Join Date
    Aug 2007
    Location
    near the swamp
    Posts
    788

    Re: need help - replace a part for Polaris Booster Pump pb4

    pvc glue, primer, pipe cleaner

    looks like all you need is p133, go down to your local pool store and pick one up. Should be about $5-8 or so.

  5. #5
    Senior Member
    Join Date
    Jul 2009
    Location
    Massachusetts
    Posts
    140

    Re: need help - replace a part for Polaris Booster Pump pb4

    i would totally go to my local store, but no one seems to carry it - so I have to special order it, pay for shipping, etc.. .. that's why I'm trying so hard to make sure that it'll work with my existing hose, before I order it.

    If i were to just try to glue it in the interim, since the pool needs a good cleaning before July 4th.. I can figure out how to use PVC glue, but what do I do with the primer and pipe cleaner? sorry to be such a pain.. I just hate going into this without a clue..

    Thanks again..
    Patty
    27,500 gallon gunite pool with waterfall (built 2002 - owner as of 2009), Aerotemp / Aquacal heat pump AT12000-A, Hayward DE4800 Filter, AOS UST1202 Motor, Hydro-King T104P201 Timer, Meyco pool cover, Pentair Model 320 Auto Chlorine Feeder. Located in Massachusetts.

  6. #6
    Senior Member
    Join Date
    Jul 2009
    Location
    Massachusetts
    Posts
    140

    Re: need help - replace a part for Polaris Booster Pump pb4

    i'm going to wing it and see if someone at lowes can help me.. wish me luck.
    thanks
    27,500 gallon gunite pool with waterfall (built 2002 - owner as of 2009), Aerotemp / Aquacal heat pump AT12000-A, Hayward DE4800 Filter, AOS UST1202 Motor, Hydro-King T104P201 Timer, Meyco pool cover, Pentair Model 320 Auto Chlorine Feeder. Located in Massachusetts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •