Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Having problems with my IC40 Cell AGAIN!!

  1. Back To Top    #1

    Join Date
    Mar 2007
    Murrieta, CA

    Having problems with my IC40 Cell AGAIN!!

    Previous issue:

    So, barely 18 months later, I am having almost the identical problem.

    About two weeks ago, my IC40 stopped producing chlorine. Checked my lights, and the Cell light is flashing green, indicating to Clean Cell. Diagnostics on my Easytouch controller confirmed this. So, I took it apart and looked at it. No scale to be found, although there were some grass clippings and leaves which were stuck in the blades. I went ahead and cleaned it anyway, with approx 20% Muriatic Acid (31% strength). No success. Cell Light is still flashing. Since then, I've cleaned it again with about 40-50% Muriatic acid, but the problem persists.

    During this time, the unit was also reading very high salt levels (~6000 ppm). I took a water sample to Leslie's who measured my salt at 3200 ppm. I cleaned my cartridge filters today and again took my cell off to inspect. Some clippings and leaves, so I just sprayed those out. When I remounted the cell, I got a different reading of 2250 ppm. Eventually, the salt levels stabilized at around 2900 ppm, but the cell light is still flashing.

    Any ideas? I'm getting frustrated with this. The SWG is very convenient when it's working, but this is going to get expensive. The first time it happened, the unit was replaced under warranty. But now, I'll probably have to spring for a whole new cell out-of-pocket. I can't afford to buy a new cell every 18-24 months.
    ~13500 gallon gunite pool, Pentair Intelliflo 4x160, Pentair 520 SF cartridge filter, Pentair MasterTemp 400 NG heater
    Pentair Easytouch with IC40 SWCG, Hayward Navigator on dedicated suction line

  2. Back To Top    #2

    In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Silicon Valley, CA

    Re: Having problems with my IC40 Cell AGAIN!!

    Quote Originally Posted by peterl1365
    I can't afford to buy a new cell every 18-24 months.
    Call Pentair right away (before any more time goes by) and tell them this. There is obviously a manufacturing problem here. And they should make it right This problem has seemed to level off in my area for the time being. They were dropping like flys almost a year ago.

    How old is all your equipment?
    Was it all purchased together?

    If you buy a Pentair filter, pump, and one other piece of equip (intellichlor), you get your warranty extended to three years on those parts, and any other Pentair unit that you got at the same time.

    Keep pushing, and ask for the regional reps phone number if you get no satisfaction.
    Factory Warranty Station for:
    Jandy, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts