Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: St rite filter multi port valve

  1. Back To Top    #1

    St rite filter multi port valve

    A problem - I have been fighting cloudy water - done everything I can think on the chemical side. I took off the top of the filter - the white basket type thing that is supposed ( i think) to be attached to the multi port valve was NOT attached. It was sitting on the lateral tube completely separate from the valve. Is it possible this is the problem - it seems as though the water would not be filtered correctly? The water would just just sort of wander down through the sand instead of going through the laterals? Is this possible? What should I do at this point?
    Henderson, TN
    18X36 inground Vinyl pool - 14 years old - new liner 1 year ago
    26,800 gallon
    Sand filter - Christal Flo - Hi rate 300 Lbs of sand, Hayward pump 1.0 HP

  2. Back To Top    #2

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Sebring, Florida

    Re: St rite filter multi port valve

    I can't picture the device you are referring to but I can help a little.

    Unless you backwash, water entering the filter has to go out through the laterals. You may have a filter with some problems but I don't think it's causing your cloudy water.

    There are lots of reasons for cloudy water, but most of them involve improper water chemistry.

    If you can post a full set of current test results, we will be able to possibly help. Without them we can only guess.
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts