Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Autofill valve leaking

  1. Back To Top    #1

    Autofill valve leaking

    I have an autofill valve that is constantly running. Its a toilet float type.

    The leak is around where the brass/metal valve is encased by the plastic/rubber grommet type fitting. Any ideas on how to repair?

    Thanks
    Blessed is the man who can laugh at himself for he will never cease to be amused.
    To teach is to learn twice.
    My Pool. 20 x 40 120,000 litres (about 30k gal) sand filter, a pump of some type...lol & a bunch of neighbourhood kids.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Autofill valve leaking

    Welcome to TFP!

    It is tricky to diagnose without seeing it, but I cna think of two common possibilities. Most like it is leaking around the threaded fitting where the brass valve is screwed into the plastic fitting. If so, you can remove it, clean the threads, apply pipe dope, and re-install. Another possibility is that the plastic fitting is cracked, in which case the plastic fitting will need to be replaced.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: Autofill valve leaking

    Here is a pic. The leak can be seen by my finger where the metal valve meets the plastic fitting. The plastic fitting does not appear to have any cracks.

    So the metal valve actually screws out? I tried but it wouldn't budge.
    Attached Images Attached Images
    Blessed is the man who can laugh at himself for he will never cease to be amused.
    To teach is to learn twice.
    My Pool. 20 x 40 120,000 litres (about 30k gal) sand filter, a pump of some type...lol & a bunch of neighbourhood kids.

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,340

    Re: Autofill valve leaking

    The metal valve should screw out of the plastic fitting. Looks like it's got some teflon tape on it so you may get by with removing it, cleaning it up and either using paste or t-tape again and screwing it back in. Be sure to inspect the brass piece to make sure it isn't cracked.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  5. Back To Top    #5

    Re: Autofill valve leaking

    You are correct, I removed the valve and the threading had been stripped in a couple of areas (who knows how, maybe at install or pre-install). I managed to apply enough teflon tape to stop the leak now, and have ordered a replacement valve from the manufacturer.

    Thanks for the replies.
    Blessed is the man who can laugh at himself for he will never cease to be amused.
    To teach is to learn twice.
    My Pool. 20 x 40 120,000 litres (about 30k gal) sand filter, a pump of some type...lol & a bunch of neighbourhood kids.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •