Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Need some filter help

  1. Back To Top    #1
    lynns's Avatar
    Join Date
    Jun 2010
    Location
    New Jersey
    Posts
    50

    Need some filter help

    First, I am new here and very very new to pool care. Great forum. Already learned a lot just reading some posts!!

    My problem: We have a fiberglass inground pool that was installed last fall. It is now up and running for the summer. We have been working on getting it clean and ready. Today we noticed while vacuuming it that dirty water was coming back out of the return jets. We shut the system down and checked the filter (Pentair Clean and Clear). We noticed that the rubber end cap on the filter cartridge is cracked and the "bands" around the pleats are broken. Could this be causing dirty water to get back in the pool? I read that this could be caused from the filter being "plumbed backward". I also read that the filter cartridge has an average life of 3 years. I just don't see how this would happen after the pumps only been running for about 2 months. (The pool was winterized right after installation)

    Please forgive my lack of pool terminology and knowledge. We have not received any support from the pool installers and it's becoming REALLY FRUSTRATING!
    14x30 Viking "Santa Barbara" Fiberglass Pool 12,500 gallon
    IntelliFlo Variable Speed Programmable Pump
    Salt Water Generator with AquaRite Electronic Chlorinator
    Pentair Clean and Clear Cartridge Filter

  2. Back To Top    #2
    frustratedpoolmom's Avatar
    Join Date
    May 2007
    Location
    SWSuburban Chicago, IL
    Posts
    11,965

    Re: Need some filter help

    The cracked end cap is the likely problem - the broken bands don't hurt anything.
    The pump has been running for 2 months? Is this the first cleaning?
    Can you provide more info about the pool specs/equipment?
    Go to User Control Panel, then Profile, then Edit Signature.
    Helpful links: Pool School; CYA/Chlorine Chart
    24' round AG pool, 52" high, Raypak heater; Waterway 2 spd Pump;
    150 Sq ft. Clearwater Cartridge Filter; Former and DISSATISFIED "Pool Frog" owner
    http://www.PerfectlyClearPoolService.com

  3. Back To Top    #3
    lynns's Avatar
    Join Date
    Jun 2010
    Location
    New Jersey
    Posts
    50

    Re: Need some filter help

    Ok. I edited my signature. Yes, the pump was dewinterized 2 months ago and has been running on a 8am to 8pm schedule. This was the first cleaning we did to the filter. We only did it because we saw the dirty water coming out of the returns. The installer said that it should only need cleaning once or twice a season. It really wasn't that dirty but we just figured we'd check it anyway.

    Todays new problem, the salt reading has been really low since the pool was started up. We added some salt and got it to read 1700 (still too low). Today we bought salt test strips and they are reading 4200.

    UGHHHH!!!!!!
    14x30 Viking "Santa Barbara" Fiberglass Pool 12,500 gallon
    IntelliFlo Variable Speed Programmable Pump
    Salt Water Generator with AquaRite Electronic Chlorinator
    Pentair Clean and Clear Cartridge Filter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •