Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: SWG T-15 not working

  1. Back To Top    #1

    SWG T-15 not working

    I was told the T-15 was bad it was not reading any salt than would read 2200.
    We recieved the new SWG the service light is still on and the salt reads 0000.
    No they are saying we need a new circuit board if the circuit board was bad why would it read any thing.
    how do I reset the trouble light?

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Pleasanton, CA

    Re: SWG T-15 not working

    Which controller do you have? For the Aqualogic, you can go to the diagnostic menu, click right then click + buttons.
    Hydraulics 101; Pump Ed 101; Pump and Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater, ThePoolCleaner

  3. Back To Top    #3

    Re: SWG T-15 not working

    If its the Aqua-Rite, Push and hold diagnostic button. Have you recalibrated your board? Push diagnostic button until you get to instant salinity (as per manual) and move the (Off, Auto, Superchlorinate Button) up to Super Chlorinate and back to Auto. See if that works first!

  4. Back To Top    #4

    Re: SWG T-15 not working

    Sounds like mine and it was the board. Seems the most common is the frying of the board electornics. I think there may even be a couple threads on here about this... ... lightning/
    South Florida. 20,000 gallons; 16x35 rectangular gunite; Pentair Intelliflo VF Variable Speed Pump; Hayward cartridge; Aqua Rite SWG. Dolphin Oasis Z5 Robotic Pool Cleaner; Kopec 540sc Electric Heat pump pool heater; Pool built in Spring 2004.

  5. Back To Top    #5

    Join Date
    Mar 2009
    Huntsville, AL

    Re: SWG T-15 not working

    There is also this link that talks about a repair to the circuit board, but I think it may be a different error code than what you are getting:
    27K gal, IG vinyl, 1.5 HP pump, 24" sand filter, Goldline Aqua Plus SWG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts