Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Help please. Jets and polaris are really weak...

  1. Back To Top    #1

    Join Date
    Jun 2007
    Location
    Austin, Texas - best city in the world
    Posts
    22

    Help please. Jets and polaris are really weak...

    I live in central texas. We got hammered with rain for about 35 days. My pool turned into a green algae swamp because of it. I finally got it all clean, and water is almost crystal clear now finally after almost 2 weeks of dealing with it.

    I noticed the pressure coming out of the jets had gotten really really weak. After some researching, I backwashed the pool for about 15 minutes and cleaned out the pump basket. Looks like that took care of that problem. jets pressure is strong again.

    However, the Polaris which worked great before all the algae is still really weak. It barely pushes along now. The stream that comes out the back end of it to push it along is not strong enough to make it roll. I hoped cleaning out the pump basket would fix it. but it didn't..

    my pool is almost 100% clean, if the polaris worked like it used to, Im sure it would clean all the last bits of crud in the pool...

    TIA
    Tampa, Florida

    17,000 gallon IG pool, DE FIlter, pebble finish, 1 1/2 hp, 8 4x10 solar panels, screen cage, combined ozone/SWG.

  2. Back To Top    #2
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    9,089
    Is your Polaris on a booster pump? If so, I'd inspect the impeller for debris.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  3. Back To Top    #3

    Join Date
    Jun 2007
    Location
    Austin, Texas - best city in the world
    Posts
    22
    Quote Originally Posted by JohnT
    Is your Polaris on a booster pump? If so, I'd inspect the impeller for debris.
    im a newbie..what is a booster pump and where is the impeller?
    Tampa, Florida

    17,000 gallon IG pool, DE FIlter, pebble finish, 1 1/2 hp, 8 4x10 solar panels, screen cage, combined ozone/SWG.

  4. Back To Top    #4
    divnkd101's Avatar
    Join Date
    Mar 2007
    Location
    Pearland, TX (Houston Suburb)
    Posts
    587
    Also check the filter on the line. Some Polaris units have an inline filter on the hose that travels through the water. Keep us posted.
    MIKE

    21K Inground Custom w/ Spa (Gunite/Plaster), SWCG, Hayward Northstar, Polaris 280, Hayward Color Logics, Jandy PS-8

  5. Back To Top    #5

    Join Date
    Jun 2007
    Location
    Austin, Texas - best city in the world
    Posts
    22
    Quote Originally Posted by divnkd101
    Also check the filter on the line. Some Polaris units have an inline filter on the hose that travels through the water. Keep us posted.
    Oh, I didn't know that.. I will check that also..thanks..
    Tampa, Florida

    17,000 gallon IG pool, DE FIlter, pebble finish, 1 1/2 hp, 8 4x10 solar panels, screen cage, combined ozone/SWG.

  6. Back To Top    #6

    Join Date
    Jun 2007
    Location
    Austin, Texas - best city in the world
    Posts
    22
    happy to report that Polaris is working great again. Actually even better than it did before. I removed the hoses and found the little fiter at the end of the hose that was completely full of crud. I removed it and thoroughly cleaned it. Re-attached filter, re-attached hose, crossed my fingers and let her rip. It started going much better and even started to climb the walls and steps..hahaha.

    thank you all for the recommendations.

    I have successfully made it through my first big algae mess. My pool was a green swawp two weeks ago. Its now crystal clear and I was able to get in it yesterday. All thanks to TFP!
    Tampa, Florida

    17,000 gallon IG pool, DE FIlter, pebble finish, 1 1/2 hp, 8 4x10 solar panels, screen cage, combined ozone/SWG.

  7. Back To Top    #7
    divnkd101's Avatar
    Join Date
    Mar 2007
    Location
    Pearland, TX (Houston Suburb)
    Posts
    587
    Glad to hear the success. Thanks for the update.
    MIKE

    21K Inground Custom w/ Spa (Gunite/Plaster), SWCG, Hayward Northstar, Polaris 280, Hayward Color Logics, Jandy PS-8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •