Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 4 of 4

Thread: Aquarite with T15 cell low salt and inspect cell light on

  1. #1
    Junior Member
    Join Date
    May 2010
    Location
    Baltimore,Md 21236
    Posts
    2

    Aquarite with T15 cell low salt and inspect cell light on

    I just purchased a new T15 cell for my 18X36 in-ground vinyl liner pool due to the low salt and inspect cell lights coming on after a few seconds of sliding the switch to AUTO. The pool is balanced and I still have the same results. Now the first reading is 700 all the rest seem to be correct Temp and so on. I did inspect the board and didn't see any burnt spots and was told by Goldline that since I got 5 seasons out of my original T15 cell it was time to replace it. After reading the manual 3 times I still can't find a possible solution to my issue. Has anyone else had this issue? I have search the forum but couldn't find anybody with this same issue. I am have read many post on this site and wish I had found this site before I purchased a pool. I think I might have joined a swim club instead. Thank you in advance for any suggestions you might have.

    Chris
    23K Gallons • IG • Plaster • Cartridge Filter • Solar Heating • TF100 Test Kit • Attached Spa w/ Spillover

  2. #2
    Administrator JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    34,659

    Re: Aquarite with T15 cell low salt and inspect cell light on

    Welcome to TFP!

    Could you post a full set of water test results, including water temperature? What you call balanced and what we call balanced are likely to be different. Low salt and inspect cell are most likely to come on when the salt level is low and the water is cold, though there are several other possibilities.

    Check the cable between the control unit and the SWG and make sure there aren't any cuts or nicks and that it is firmly connected on both ends.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    TFP Admin. Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. #3
    Senior Member NWMNMom's Avatar
    Join Date
    Apr 2007
    Location
    Waaay NW MN
    Posts
    1,574

    Re: Aquarite with T15 cell low salt and inspect cell light on

    Mine did the same thing until my salt level was a minimum of 2900 or more and my water hit 71 degrees
    18x33x52 Buttressfree Seaspray (Wilbar) AGP - 1.5hp Pentair Maxim w/22" Pentair Meteor Sand Filter, Aqua Rite SWG System, Biltmore Walk In Steps - 2/4x20 Solar Panel Setup - Pool Rover Jr - finally hard plumbed the whole darned thing -
    Beats Driving to the Lake!

  4. #4
    Junior Member
    Join Date
    May 2010
    Location
    Baltimore,Md 21236
    Posts
    2

    Re: Aquarite with T15 cell low salt and inspect cell light on

    Created my own issue. Cell went up and I added enough salt to fill the Atlantic ocean. I misread the strips and emptied the pool a dozen times. I feel horrible for wasting all the water. I went out bought more salt read the test strips balanced the pool and the system seems to be working correctly. As a side note I will promote this site to everybody that has a pool or spa. I was at our local wholesale club and noticed a lady looking at the SWG and inquired if she was thinking about buying one. She said she did and was looking for the salt I told her to check the Home Depot or Lowes. I also told her to register troublefreepool.com because it is awesome. Thank you for creating this site.
    23K Gallons • IG • Plaster • Cartridge Filter • Solar Heating • TF100 Test Kit • Attached Spa w/ Spillover

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •