Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: sand in screen for polaris 65

  1. Back To Top    #1

    sand in screen for polaris 65

    Just replaced sand in filter (Doughboy media master). Before changing sand occasionally found small amount of sand in screen for polaris65. Now sand stops polaris from moving at least twice in 24 hour period. I have to blow out screen and replace, then all is well for a while. I bought sand at very reputable store, in business 20 years or longer. Before changing sand, filter tilted to one side, I assumed this was the cause of sand deposit. Filter is now level.
    Also I recently replaced the valve cover due to a crack in the housing.
    Any clues?

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: sand in screen for polaris 65

    Did you check the underdrain assembly and feed pipe for cracks and while you had the sand out?
    What mesh was the sand you bought?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: sand in screen for polaris 65

    I didn't inspect the pipe or assembly closely. I didn't think at the time that could be the problem. I assumed it was the tilt in the filter. The sand did not have a label identifying the mesh, just the warning that it was silica sand and use breathing apparatus while installing. Sent the wife to pick it up. I had called the store and asked for # 20 pool sand.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts