Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Polaris tipping forward and running slow

  1. Back To Top    #1

    Polaris tipping forward and running slow

    Hi all! I'm a new pool owner! We recently bought house that came with a lovely in ground pool with spa. I have become obsessed with making it a sparkling oasis. While looking through a shed on the property I came across an old Polaris, it was missing it's tail and bag so I took it down to Leslie's to see if it was salvagable. Surprise...they were able to get it up and running pretty cheap. It ran great for about an hour but now it tips forward and the wheels have stopped turning. I believe it is a Polaris 380, it's body is opaque not clear blue so it must be an older model.
    Should I open it up and look inside or take it back to Leslie's? I don't want to pay for it to be fixed it it's just clogged.
    40K IG Plaster w/ attached IG Spa
    1.5 HP Challenger Self Priming Pump
    0.5 HP Booster pump running a Polaris 360 rover
    60sq.ft DE Filter w/ Multiport Valve
    Fort Worth, Texas

  2. Back To Top    #2

    Join Date
    Jan 2009
    Cupertino, CA

    Re: Polaris tipping forward and running slow

    If you're comfortable opening it up to look, go ahead; the problem might be obvious, like an internal hose popped off. If it's not obvious, then it's a matter of how mechanically inclined you feel; I'm not so inclined, and would take it back, especially if Leslie's is willing to warrantee their work.
    BBB "Intermediate Swimmer"
    IG plaster pool 18.5K gal, Hayward Pro-Grid DE filter, 3/4 HP Hydramax II; Polaris 380, 3/4 HP booster
    AG spa 325 gal, probably Sundance of some kind
    Water testing instructions on one page

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts