Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: My pool pump is leaking

  1. Back To Top    #1

    My pool pump is leaking

    I have a ge pool pump for my inground. When I went to open it up for the first time, it works fine. However, I noticed a lot of water coming out from what looks like the motor housing unit. At first I thought it was from the plug, but then realized it was not. Any suggestions?

  2. Back To Top    #2
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    SW Indiana

    Re: My pool pump is leaking

    Welcome to TFP!

    It's probably the shaft seal. It's repairable. If you can haul the whole works to a pool store, they can probably do it or provide you the parts. If you can post picture, somebody here can probably identify the model of the pump.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  3. Back To Top    #3
    smc's Avatar
    Join Date
    Oct 2009
    Tucson, Arizona

    Re: My pool pump is leaking

    I had mine done the first time by the final pool store (and only store I go to since) that I hauled the assembly to. The little spring seal and a few O-rings only cost $12 compared to the $400-600 the other stores wanted for a new pump. Don't let them steal your money!!!
    26k gallon IG plaster/shotcrete
    Pentair 1 HP Hydropump
    C-9419 catridge filter
    Kreepy Krauly Cruiser

  4. Back To Top    #4

    Re: My pool pump is leaking

    Thank you so much for your replies! I'll give that a try. I'll see about posting a picture.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts