Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Sand filter - newbie needs help!

  1. Back To Top    #1

    Sand filter - newbie needs help!

    Topic split by Moderator

    Hello all,

    This is my first post.
    FC 4.5
    CC 0
    Cyunuric Acid 38 ppm
    PH 7.6
    I have a 30ft round above ground. Sta-rite 1.5hp pump Cristal FloII Sand Filter, Pool holds 24,000 gallons.

    I bought the pool in early July. I have no previous pool experience. My sand filter doesn't seem to filter at all. When I vaccum I see the stuff I vaccum go right back out into the pool. I've added DE but I see it go right thru to the pool. Surely my filter should do better then this. Could something be wrong with my filter? I've checked the settings, it's on filter. What am I missing?
    30ft round Aqua Leader Above Ground
    1.5HP Sta-Rite Pump
    Cristal Flo sand Filter
    24,000 gallons

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,085

    Re: Sand filter - newbie needs help!

    Hey,

    Welcome to the forum.

    What city and state do you live in? (How long before you close the pool)

    Have you backwashed? A pic of your equipment would be helpful.

    Sand filters will do just fine. Something is wrong with yours....we'll help you figure it out.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3

    Re: Sand filter - newbie needs help!

    Quote Originally Posted by duraleigh
    Hey,

    Welcome to the forum.

    What city and state do you live in? (How long before you close the pool)
    North Central Florida, Outside of Gainesville
    Have you backwashed? A pic of your equipment would be helpful.
    Yes, I have. It seems difficult to get the pressure to go up on the psi guage hi enough to need to backwash(I do backwash after vaccuming, But when I vaccum I see the stuff blow right back out into the pool). If I get home before dark tommorow I'll get some pics.
    Sand filters will do just fine. Something is wrong with yours....we'll help you figure it out.
    Thank You, I bought the pool brand new in July, I wanted to buy quality equipment and think I did. But my experience with the dealer was good until I wrote them a check, then they didn't want to be bothered with me. My point being, I question that the filter was assembled correctly or maybe doesn't have the correct sand, I don't mean to bash them but I do question their competence.
    30ft round Aqua Leader Above Ground
    1.5HP Sta-Rite Pump
    Cristal Flo sand Filter
    24,000 gallons

  4. Back To Top    #4

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Sand filter - newbie needs help!

    Please post a picture. Is the pump exhaust plumbed in the filter intake and the filter return to the pool return?

    When the pump is off, does the multiport move smoothly?

    If the answer is yes to the above questions, plug the skimmer and return and remove the multiport from the filter tank. Drain the water. A shop vac will help speed this. Put it on the filter's drain.

    1) Is there sand in the filter?
    2) Shine a light in the stand pipe and look for cracks.
    3) Remove the sand and check the laterals.

    Let us know.

    Scott
    PoolGuyNJ
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  5. Back To Top    #5
    frankthailand's Avatar
    Join Date
    Apr 2008
    Location
    Thailand
    Posts
    152

    Re: Sand filter - newbie needs help!

    Hello welcome
    What size is the sand filter . I had a 1.5 whisperflow on ta 60 filter even pentair said it would work, but i had the same problem as you, then i changed it to 1 hp, 1 year on no more problems.
    Hello all from the land of smiles. Thailand. 5mx9mx1.5 63000L 16300 gall, pebbletex,
    pentair 1hp whisperflow, tagelus TA60 SF, swg monarch esc24 {a bit small for the tropics} 3 returns, 1 skimmer, 2 astral 100watt lights. Planned and built by me
    an AUSSIE expat living thailand for 18 years.

  6. Back To Top    #6

    Re: Sand filter - newbie needs help!

    Boy! I am actually going to put my toe in the water and try to help.

    Apart from what others said (IS there sand in the filter?)

    I have noticed that when the filter gets clogged, the output water is as cloudy as the input So the question "have you backwashed" is very possibly a start here. I am finding that after I backwash, the return water is clear. When the filter pressure builds up, the return water is cloudy. I assume there either a bypass valve, or the filter is just so clogged that the suff is being washed out back into the pool.

    I am a noob of the first water, but what are your water conditions like (tress/sand/usage of the pool etc) ? How often do you vacuum/filter and how long do you filter for?

    Just trying to give back.
    Nick
    Perth Western Australia
    ~20,000 US liquid Gal (~80000 L) inground concrete, pretty much oblong roughly 11m * 8m and 1.2 - 1.8+ m deep SWCG, 24" Sand filter, Hurlcon 1hp pump

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •