Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Polaris 380 not working

  1. Back To Top    #1
    Cabana Boy's Avatar
    Join Date
    Jul 2007
    Sacramento, CA

    Polaris 380 not working


    I have a Polaris 380 that is not working. I recently purchased it, and I might be able to return it, but I figure I "broke" I have to fix it.

    It ran fine at first. My pool was full of debris and the mesh filter clumped up quickly. I remember a pool guy telling me a few years ago (when I was inquiring about a Polaris 180 I used to have) that I should not use the filter screen. So I took it out.

    Now it isn't working.

    There is water coming out the jets that5 shoot the debris into the catch net, and water coming out the rear end. The problem is that the wheels are not turning. So I am wondering if there is debris stuck inside preventing the wheels from turning. If so, I should be able to take it apart and clean it out...correct?
    14 x 32 x 6 (ave depth) 20K gallons - IG gunite pool. Challenger 1.5 hp pump and cartridge filter.

  2. Back To Top    #2
    The pool guy gave you bad advice. The purpose of the screen is to keep debris out of the unit so it doens't mess up the belts and gears. The 180 was driven by an idler wheel so it was a bit more immune to this but the 380 is belt driven. If you disassemble it I would suspect that you will find stuff in the works and possibley a broken or misplaced belt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts