Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Hayward C1200 Locking Knob Doesn't Fit

  1. Back To Top    #1

    Join Date
    Oct 2016
    Location
    Houston, Texas
    Posts
    2

    Hayward C1200 Locking Knob Doesn't Fit

    Hey everyone, I have a Hayward C1200 and just replaced the locking knob with the CX900G. I believe this is the correct knob but it is not fitting properly on the rod. I was able to get it to screw onto the rod but there was a gap between the lid and bottom that allowed water to leak through. Messing with it, the rod has gotten stuck in the knob a few times as well. Does anyone have any ideas? I appreciate the help.

  2. Back To Top    #2

    Join Date
    Oct 2016
    Location
    Houston, Texas
    Posts
    2

    Re: Hayward C1200 Locking Knob Doesn't Fit

    Looking at it more, it seems that the knob is just hitting the rod before the filter head is sealed all the way down. Therefore, the filter head is unable to seal. It seems like the knob needs to be raised but that doesn't seem to make sense. Any ideas appreciated.

  3. Back To Top    #3

    Re: Hayward C1200 Locking Knob Doesn't Fit

    Have the same issue, any resolution??


    Sent from my iPhone using Tapatalk
    22,000 Gallon In Ground with CrystalStone (pebble) finish in Blue Ice
    Pool Pilot Digital Nano SWG
    Pentair 1.0 HP Pump
    Hayward C1200 (120 S.Ft.) Cartridge Filter
    Pentair Great White Automatic Pool Cleaner
    TF-100 Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •