Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Back swimmers in pool but no algae

  1. Back To Top    #1

    Join Date
    Sep 2015
    Dallas Texas

    Back swimmers in pool but no algae

    ive noticed several back swimmers (2 or 3) in my pool but I've consistently passed the overnight chlorine test, etc. and have seen no boatmen in the pool. in fact, I've had no algae issues whatsoever over the ~2 years I've had the pool? Thoughts about how to get rid of them? I know they are typically present to feed on boatmen (who are present to eat algae) but that logic doesn't seem to hold in my case.

    Fiberglass pool 5300 gallons (trilogy eclipse)
    Cartridge filter
    2HP hayward ecostar sp3400vsp

  2. Back To Top    #2
    Mod Squad
    Join Date
    Aug 2012
    DFW, TX

    Re: Back swimmers in pool but no algae

    It is common for people to see a few water bugs in the pool from time to time. We get a few different varieties occasionally.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts