Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pentair ultratemp not heating

  1. Back To Top    #1
    Nabortz's Avatar
    Join Date
    Aug 2016
    Location
    Jacksonville, fl
    Posts
    8

    Pentair ultratemp not heating

    New pool owner 2 months now. Pentair ultratemp 120 electric is running but not heating or heating very slowly. We're in Jacksonville FL. Had to bail because of Hurricane Mathew. I turned everything thing off. We did lose power but didn't get hit bad at all I have an enclosure and received zero debris in the pool.
    We were able to come back yesterday I turned on all equipment and everything is good to go except the heater. It appears as though it's working, cool/cold air coming out of the top, condenser clicks on, condensation on coming out the drain. Pool temp will not go above 81.
    The only thing I can see different with the pool is the water level is really high.

    Any suggestions?
    Nabs
    In-ground, Gunite, 16K Gal, 30'x15' Rectangle w/
    10'x7' Tanning Ledge cutout
    Pentair Equip
    CMP Brilliant Wonders Waterfall

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    22,917

    Re: Pentair ultratemp not heating

    Has it been serviced by an HVAC company in the last year or two? Freon needs to be checked and the compressor oil too. It is the same heat pump type of system as the HVAC in a house and should receive an annual check up.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3
    Nabortz's Avatar
    Join Date
    Aug 2016
    Location
    Jacksonville, fl
    Posts
    8

    Re: Pentair ultratemp not heating

    It's 2 months old all new Pentair equipment. Pump is running just fine.


    Nabs
    In-ground, Gunite, 16K Gal, 30'x15' Rectangle w/
    10'x7' Tanning Ledge cutout
    Pentair Equip
    CMP Brilliant Wonders Waterfall

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •