Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Did I mess things up?

  1. Back To Top    #1

    Join Date
    Oct 2016
    Location
    Dallas, TX
    Posts
    2

    Did I mess things up?

    Just purchased a home with pool recently. Trying to figure things out. Messed with the air release valve on the pool filter, and now the water in the strainer seems to be sucking in at a very intense rate.

    I've since closed the air release valve and don't have the pump on because I'm paranoid I've done something terribly wrong. Does anything look wrong with the video posted below? Do I need to do anything to fix this, or is the rate of this type of suction ok?

    Dropbox - File Oct 01, 11 22 27 PM.mov

  2. Back To Top    #2

    Join Date
    Aug 2014
    Location
    Northern IL
    Posts
    4,615

    Re: Did I mess things up?

    Looks to me like the water level is too low in your pool. It should be at mid-skimmer. Add water and you should be just fine.

  3. Back To Top    #3
    Mod Squad Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,096

    Re: Did I mess things up?

    Welcome to TFP! Let us know if increasing your water level as MarianParoo suggests resolved your issue. Nice to have you with us.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  4. Back To Top    #4

    Join Date
    Oct 2016
    Location
    Dallas, TX
    Posts
    2

    Re: Did I mess things up?

    That did the trick. Thank you for your help and the warm welcome.

    My pool filter air relief valve seems to be leaking a little as well. Would you recommend some teflon tape to seal it up?

    Thanks

  5. Back To Top    #5
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    34,883

    Re: Did I mess things up?

    Those are release valves usually have an o ring, tape would not help. Could be a small piece of debris caught in it.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •