Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Hayward Aqua Plus control panel bit the dust - what to replace it with?

  1. Back To Top    #1
    sdmeyer97's Avatar
    Join Date
    Jun 2011
    Location
    Charleston, IL
    Posts
    38

    Hayward Aqua Plus control panel bit the dust - what to replace it with?

    Our pool and automation system is 5 seasons old; we are in Illinois. I have had repeated issues with the sense and dispense component as well as the control panel itself. I've lost count of the number of times the "Check System" light was on......Anyway, today it finally bit the dust. We are going to just go ahead and close the pool for the season, however, we'll obviously need a new control panel for next year. I'm not crazy about the Hayward product line due to the issues I've encountered....but, the rest of the system is Hayward. Do I have to stick with Hayward's control systems? Has anyone "jumped ship" to another brand with good results. Can I mix and match or should I consider replacing the entire system? Thanks.
    30,000 gal Inground Vinyl Liner Dive pool,Tristar pump, Hayward C5025, SwimClear Cartridge Filter, HeatPro 250k btu gas heater, Hayward Aqua Plus Goldline with salt chlorine generation,
    Hayward Sense & Dispense. Not that I understand this stuff........

  2. Back To Top    #2

    Re: Hayward Aqua Plus control panel bit the dust - what to replace it with?

    The AquaPlus is a good unit. What’s wrong with yours?

  3. Back To Top    #3
    sdmeyer97's Avatar
    Join Date
    Jun 2011
    Location
    Charleston, IL
    Posts
    38

    Re: Hayward Aqua Plus control panel bit the dust - what to replace it with?

    Just one equipment piece issue after another. Since it was first installed, the Check System Light on the control panel would come on indicating an issue (actually very frequent, at least weekly if not more often). Didn't matter if I addressed what it indicated was out of whack, light would come back on. Tried adjusting (thru Pool Company) levels so many times with little luck....I believe I have had 3 sets of sensors for the Sense & Dispense component, control board was replaced and salt cell replaced 3 times and now today I noticed that my heater said the water was not flowing. Tried to flip the breakers on control panel, used reset button on the panel and double checked the breaker in our house...and no luck.
    30,000 gal Inground Vinyl Liner Dive pool,Tristar pump, Hayward C5025, SwimClear Cartridge Filter, HeatPro 250k btu gas heater, Hayward Aqua Plus Goldline with salt chlorine generation,
    Hayward Sense & Dispense. Not that I understand this stuff........

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •