Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Hayward HM250 ED2 Heater "BOOMing" on start up

  1. Back To Top    #1

    Join Date
    Jan 2015
    Location
    Nevada
    Posts
    14

    Hayward HM250 ED2 Heater "BOOMing" on start up

    Got on issue with my pool heater. When the command is sent to start I can hear the ignitor clicking away but it does not "fire" up like normal. After awhile it will go BOOM igniting all the gas from start. Any ideas?
    Custom 12,500 IG Pebbletech pool with attached SPA (Built 1996), Cartridge Filter, Hayward EcoStar Var Speed Pump (junk after 4 yrs) REPLACED with Hayward TRISTAR Dual Speed SP32202EE, SWG Aqua T-Cell-15, Hayward Pro Logic PS-8 Pool Controller, Wireless Base Transmitter, Wireless Remote, Hayward Pool Heater HM250 (1996 manufacture date stamped), Zodiac MAX 8 Pool Cleaner

  2. Back To Top    #2

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,438

    Re: Hayward HM250 ED2 Heater "BOOMing" on start up

    Sounds like a good disassembly and cleaning is in order. Probably a clogged up burner tube near the pilot assembly.

    Dan
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  3. Back To Top    #3

    In the Industry
    Hayward Pool's Avatar
    Join Date
    Oct 2014
    Location
    Elizabeth
    Posts
    343

    Re: Hayward HM250 ED2 Heater "BOOMing" on start up

    Also clean the gas orifices.
    Hayward Pool Tech
    80+ Years of Technologically Advanced Pool Product Manufacturing
    poolside@haywardnet.com

  4. Back To Top    #4

    In the Industry
    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    2,806

    Re: Hayward HM250 ED2 Heater "BOOMing" on start up

    If cleaning doesn't fix this, let us know.
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  5. Back To Top    #5

    Join Date
    Jan 2015
    Location
    Nevada
    Posts
    14

    Re: Hayward HM250 ED2 Heater "BOOMing" on start up

    Major cleaning effort did the job. Ignition and pilot light works like a charm. I even pulled off the exhaust vent and top then cleaned the copper tubes above the burner which had some major green corrosion and rusty metal pieces. I cleaned all the connections. The pilot light and ignition is buried underneath the unit so it took a little inginuity to get a steel brush that deep. I wanted to do as much as I could before pulling out the burner if that did not solve the issue. All good so far.
    Custom 12,500 IG Pebbletech pool with attached SPA (Built 1996), Cartridge Filter, Hayward EcoStar Var Speed Pump (junk after 4 yrs) REPLACED with Hayward TRISTAR Dual Speed SP32202EE, SWG Aqua T-Cell-15, Hayward Pro Logic PS-8 Pool Controller, Wireless Base Transmitter, Wireless Remote, Hayward Pool Heater HM250 (1996 manufacture date stamped), Zodiac MAX 8 Pool Cleaner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •