Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: High Pressure Low Flow

  1. Back To Top    #1

    Join Date
    Sep 2016
    Las Vegas

    High Pressure Low Flow

    Hi everyone. I am new to owning a pool. I have a problem that I can't figure out. I have 35 psi in my clean and clear plus (either 420 or 520) filter. I am not sure which I have. The returns to the pool or spa are very low pressure. When I turn on just spa jets, there is no jet motion in the spa. Could my pump not be primed? Could I have a leak in the filter somewhere? I did recently remove the filter top to clean the cartridges. Could I have overtightened the strap? I have new cartridges (PCC105) arriving Wednesday. I also noticed small air bubbles coming from the pool and spa returns. Yesterday, I also noticed a wet spot at the top of the filter where the pressure guage conencts to the filter body. The pump had been running for several hours.

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Pleasanton, CA

    Re: High Pressure Low Flow

    Welcome to the forum!

    The pressure is high because something is restricting the flow (post filter gauge).

    You might be fighting an algae bloom too. What does the water look like?
    Hydraulics 101; Pump Ed 101; Pump and Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater, ThePoolCleaner

  3. Back To Top    #3

    TFP Guide
    Jimrahbe's Avatar
    Join Date
    Jul 2014
    Bedford, TX

    Re: High Pressure Low Flow


    Welcome to TFP.. you will love it here..

    It is impossible to clean the cartridges while they are still in the housing. You need to take them out, and clean each one individually, with a high pressure nozzle on the end of a garden hose. It will take you 5 or 10 minutes per filter to clean them properly.

    As Mark says above, you may also have an algae bloom causing your filters to clog quickly.

    What test kit are you using to test your water?


    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP5200 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts