Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Auto-Cover problem

  1. Back To Top    #1

    Join Date
    Sep 2016
    Fairfax Station

    Auto-Cover problem

    Hi all: My auto cover suddenly stopped working yesterday. I first checked the circuit breaker and the GFCI, and both are fine. Next I checked the auto-cover switch (Coverstar brand) and saw that the green light on it doesn't lit! So very likely that's the problem! What should be my next step? Should I buy the switch (coasting ~150 bucks) and replace it myself, or call Coverstar to schedule a troubleshooting visit? Please advise! Thx
    Hi everybody. This is bqv from Virginia. My 10 years old in ground pool is 16 by 45 ft. with Coverstar auto-cover. Have problem with the cover yesterday.

  2. Back To Top    #2

    TFP Guide
    bmoreswim's Avatar
    Join Date
    Jul 2012
    Central MD

    Re: Auto-Cover problem

    My Coverstar switch (Wi-Fi version) went bad earlier this year. After checking the breaker I ordered the standard switch and replaced myself with no issue. Certainly worth a try.
    18'x38' Rectangle (3'-8 1/2' deep w/ diving board) - 27K gal. Saltwater w/ gray plaster
    Hayward equipment (cartridge filter, 2-speed pump, salt cell, automation) View Our Build
    Coverstar automatic pool cover | StoneMakers concrete retaining wall and decking
    Groundbreaking: 2/14/13 | Plaster: 5/21/2013 | First Swim: 5/30/2013

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts