Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Low PSI on DE Filter

  1. Back To Top    #1

    Join Date
    Sep 2016
    Location
    Wallingford, CT
    Posts
    3

    Low PSI on DE Filter

    New homeowner here! We have a 25,000 gallon IG pool with a Pentair DE Filter. Prior homeowners did not do a great job with cleaning and maintenance.

    We've gotten the hang of vacuuming and back washing. Tonight I added the step of rinsing. After rinsing, I went to start the filter in the filter position and the water was slow to go through the filter and back through the returns; almost like there was a 90 second delay. Since then, the PSI has been low-around 2-3 PSI.


    Is this normal or did I screw something up? I grew up with an above ground pool with a sand filter but in grounds and DE filters are new to me.

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,083

    Re: Low PSI on DE Filter

    Do you have a VS pump?
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3

    TFP Guide


    Join Date
    Feb 2015
    Location
    Chandler AZ
    Posts
    744

    Re: Low PSI on DE Filter

    Did you add DE back into the filter?
    If so, how much?
    What's the brand and model number of your filter and pump?

    Please fill out your signature with your pool details so we know what equipment you have.
    Here's how to set up your signature: Pool School - Read This BEFORE You Post
    Gene
    ​12,300 gal IG play pool - Pebbletec - built 10/1999 || Hayward S360SX 36" sand filter || Hayward Ecostar SP3400 VSP || A&A In-Floor cleaning system || Quik Water Leveler || Quik Dek-clor (limited use)
    TF-100 testkit / Speedstir - A good test kit is not an expense, it's an investment

  4. Back To Top    #4

    Join Date
    Sep 2016
    Location
    Wallingford, CT
    Posts
    3

    Re: Low PSI on DE Filter

    You cannot add a signature when you are mobile. I have a Pentair FNS filter 36. I fixed the issue myself by cleaning the impeller.

  5. Back To Top    #5
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Low PSI on DE Filter

    Given you were moving the multi-port valve, I might suspect a spider gasket issue or just a valve clog of some sort. Try the recirculate mode and then back to filter.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •