Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 17 of 17

Thread: Coverstar Ripped - 4 days old

  1. Back To Top    #1
    cjpwalker's Avatar
    Join Date
    Aug 2016
    Location
    Yakima, WA
    Posts
    46

    Coverstar Ripped - 4 days old

    PB is stumped. It rolled up fine, then on the way back out it hung. Backed it out, and then forward again per the manual - and this...

    Monday he will begin the fight with the manufacturer.





    The webbing along the edge is also badly skun up, and ripped through in a couple of places - looks like 10 years of wear. Can't explain it - has opened and closed flawlessly since it went in Monday.
    16' x 34' 16,000 gallon | IG Vinyl | Pentair Tagelus sand filter | Jandy 2hp epump | AquaPro PRO1300 heat pump | Coverstar auto cover | Taylor K-2006 | built August, 2016.

  2. Back To Top    #2
    Mod Squad woodyp's Avatar
    Join Date
    Apr 2010
    Location
    East Texas
    Posts
    7,423

    Re: Coverstar Ripped - 4 days old

    looks like ye olde manufacturer defect to me.
    16x32x52" Steel Cornelius Miramar AGP Vinyl liner 13,100 gal. Buried 2 ft.
    2 Speed Hayward Power-Flo Matrix 85 g.p.m. 22" 250lb. sand filter hard plumbed
    Pool Rover Jr., Pool Blaster Max, Diver Dave TF100 Test Kit/Speed Stir
    Margaritaville Frozen Concoction Maker, Liqour Chiller, & Drink Mixer & Party Tub----Collect 'um all!

  3. Back To Top    #3

    Re: Coverstar Ripped - 4 days old

    I would suspect an installation error. If the tear wasn't there initially, it's likely that something sharp cut the cover. Check the top of the back wall for sharp spots.

    Do you have a picture of the top of the back wall and well area?

  4. Back To Top    #4

    Join Date
    Aug 2014
    Location
    Northern IL
    Posts
    4,617

    Re: Coverstar Ripped - 4 days old

    I tend to agree with James. I asked a cover-star expert to peek at your thread.

    What is that silver thing at the top of the last pic?

  5. Back To Top    #5
    cjpwalker's Avatar
    Join Date
    Aug 2016
    Location
    Yakima, WA
    Posts
    46

    Re: Coverstar Ripped - 4 days old

    Quote Originally Posted by MarianParoo View Post
    I tend to agree with James. I asked a cover-star expert to peek at your thread.

    What is that silver thing at the top of the last pic?
    Bonding cable. Manufactured that way.

    We had the lid off and looked everything over, ran it in and out several times and couldn't replicate the problem. There is also heavy wear along the webbing/bead on the edge, too that isn't pictured - wore a hole in it in a couple of spots near the tear. You can see it when it's wound up on the drum beyond the track.
    16' x 34' 16,000 gallon | IG Vinyl | Pentair Tagelus sand filter | Jandy 2hp epump | AquaPro PRO1300 heat pump | Coverstar auto cover | Taylor K-2006 | built August, 2016.

  6. Back To Top    #6

    In the Industry

    Join Date
    Dec 2015
    Location
    Lehi, UT
    Posts
    22

    Re: Coverstar Ripped - 4 days old

    Is the tear in line with a lid bracket? if the cover is run without the lid on or if it pops up then it can tear the cover.

    When you open the cover all the way can you feel space around the entire cover in the box.

    It looks like there is a cut leading up to the tear. Maybe a screw or edge that is catching the cover. I would also check the guide feed where the cover goes into the track to make sure it is tightened.

  7. Back To Top    #7
    cjpwalker's Avatar
    Join Date
    Aug 2016
    Location
    Yakima, WA
    Posts
    46

    Re: Coverstar Ripped - 4 days old

    Looks like it's rolling crooked on the drum among other things. Pool builder has been out twice to look, and CoverStar rep is coming to the house tomorrow... we'll see. I'm planning on getting the cover replaced one way or another, but definitely don't want it to happen again.
    16' x 34' 16,000 gallon | IG Vinyl | Pentair Tagelus sand filter | Jandy 2hp epump | AquaPro PRO1300 heat pump | Coverstar auto cover | Taylor K-2006 | built August, 2016.

  8. Back To Top    #8
    wjr75's Avatar
    Join Date
    Jun 2013
    Location
    IL
    Posts
    724

    Re: Coverstar Ripped - 4 days old

    The experience I have had with them that there is a guide under the lid right before it is fully closed that will cause the damage. It sticks out about 3 inches and has ripped my seems on my old cover. I don't like the look of that metal bonding thing either.
    Inground 22k gallon gunite 15x31 main pool, 15x7 wading pool/sunning deck, hot tub/with overflow (9' octagon with limestone top) & slide NSWG, Aqua Blue Pebble Sheen
    Filter dual cartridge Sta-rite 450sq/ft, TF-100 Test Kit
    Heater Raypak 2100 400k btu cupro-nickel exchanger
    Auto pool cover, Polaris 280 auto pool cleaner, Jandy AqualinkRS8 Remote Control System

  9. Back To Top    #9

    Join Date
    Aug 2014
    Location
    Northern IL
    Posts
    4,617

    Re: Coverstar Ripped - 4 days old

    Please be sure to let us know what the CoverStar rep says.

  10. Back To Top    #10
    cjpwalker's Avatar
    Join Date
    Aug 2016
    Location
    Yakima, WA
    Posts
    46

    Re: Coverstar Ripped - 4 days old

    Couple more pics from another jam today (we're still using it). Same side, caught when opening. Pics aren't very good, but you can see it "walks" off the roll.





    Bonding is from the mfr. and runs inside the webbing along with the edge bead. The exposed part never goes under the lid or onto the roll.

    I'll post when I get some info about tomorrow's visit. I'll likely be at work when they're here.
    16' x 34' 16,000 gallon | IG Vinyl | Pentair Tagelus sand filter | Jandy 2hp epump | AquaPro PRO1300 heat pump | Coverstar auto cover | Taylor K-2006 | built August, 2016.

  11. Back To Top    #11
    cjpwalker's Avatar
    Join Date
    Aug 2016
    Location
    Yakima, WA
    Posts
    46

    Re: Coverstar Ripped - 4 days old

    Got a text from our builder today: "Going to get new one ordered, I will take care of it."

    I don't think anybody came out to the house. I have no idea what the conversation was between him and the mfr. Sucks if he has to eat the cost of the cover... If that's the case, I'm glad he's stepping up and taking care of it, though. I assume whatever issue is causing this will be resolved.
    16' x 34' 16,000 gallon | IG Vinyl | Pentair Tagelus sand filter | Jandy 2hp epump | AquaPro PRO1300 heat pump | Coverstar auto cover | Taylor K-2006 | built August, 2016.

  12. Back To Top    #12

    TFP Guide

    bmoreswim's Avatar
    Join Date
    Jul 2012
    Location
    Central MD
    Posts
    2,538

    Coverstar Ripped - 4 days old

    All signs point to improper installation. Walking off the roll is not a cover defect. Great that he's going to git-r-done.
    Maybe he'll learn from his mistake (if it was his mistake). My hope is I learn from mine too.
    18'x38' Rectangle (3'-8 1/2' deep w/ diving board) - 27K gal. Saltwater w/ gray plaster
    Hayward equipment (cartridge filter, 2-speed pump, salt cell, automation) View Our Build
    Coverstar automatic pool cover | StoneMakers concrete retaining wall and decking
    Groundbreaking: 2/14/13 | Plaster: 5/21/2013 | First Swim: 5/30/2013

  13. Back To Top    #13

    Re: Coverstar Ripped - 4 days old

    I hope he figures out what caused the problem in the first place, otherwise it's going to keep happening.

  14. Back To Top    #14

    In the Industry

    Join Date
    Dec 2015
    Location
    Lehi, UT
    Posts
    22

    Re: Coverstar Ripped - 4 days old

    From your pictures I can see that the track was installed incorrectly. This is most likely the cause of the tear.
    The encapsulation is too far into the box, this has caused the track to be too far into the box. The guide feed on the end of the track should only be 1 - 2 inches into the box from the wall. There is a long bolt the goes through the guide feed and track. This hangs down below the track and is most likely the cause of your tear.

    Make sure that they shorten up the track so it is closer to the wall of the box.

    I also noticed that they didn't bong the mechanism or the track on that side.

    This could never be a safety issue but could be an inspection issue. Since you are well past that stage it shouldn't be an issue for you, it is just a sign of a less than perfect installation.

  15. Back To Top    #15
    cjpwalker's Avatar
    Join Date
    Aug 2016
    Location
    Yakima, WA
    Posts
    46

    Re: Coverstar Ripped - 4 days old - REPLACED!

    PB came through, and the replacement cover was installed today!

    Honey Badger called it -- Both the encapsulation and the track are now cut back. My guess is PB knew it right off the bat -- the owner anyway -- he's done a lot of these covers.

    In any case, no additional cost to me, the new cover operates well, and rolls up evenly. Woot!

    Also, to address the lack of bonding that was mentioned - that was on me. My employer has an electrical division, and I took advantage of the employee discount for all of the electrical for the build. I am taking care of the final terminations myself. The inspector noticed the bonding, but signed off anyway after I explained that the cover was being replaced. I'll finish that up this weekend - connecting both ends of the mechanism to the main bonding wire.
    16' x 34' 16,000 gallon | IG Vinyl | Pentair Tagelus sand filter | Jandy 2hp epump | AquaPro PRO1300 heat pump | Coverstar auto cover | Taylor K-2006 | built August, 2016.

  16. Back To Top    #16

    Join Date
    Aug 2014
    Location
    Northern IL
    Posts
    4,617

    Re: Coverstar Ripped - 4 days old

    Good news! Glad everything is fixed.

    Honey Badger is the go-to guy for sure!!!! He certainly has helped me a ton with my issues. So grateful.

  17. Back To Top    #17

    TFP Guide

    bmoreswim's Avatar
    Join Date
    Jul 2012
    Location
    Central MD
    Posts
    2,538

    Re: Coverstar Ripped - 4 days old

    Excellent. Glad to hear it.
    18'x38' Rectangle (3'-8 1/2' deep w/ diving board) - 27K gal. Saltwater w/ gray plaster
    Hayward equipment (cartridge filter, 2-speed pump, salt cell, automation) View Our Build
    Coverstar automatic pool cover | StoneMakers concrete retaining wall and decking
    Groundbreaking: 2/14/13 | Plaster: 5/21/2013 | First Swim: 5/30/2013

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •