Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Jandy Dev60 tank clamp

  1. Back To Top    #1

    Join Date
    May 2016
    Camarillo, CA

    Jandy Dev60 tank clamp

    Does anybody have any experience with the Jandy DEV60? I just finished cleaning the filter grids and am trying to reinstall the tank clamp. The manual says to tighten the clamp to within 1/16th of an inch...which it was before I disassembled. I got it to about an 1" and it started screeching with every turn of the wrench. I'm afraid I will damage the tank or clamp if I continue. I cleaned the clamp and the tank before I began installing and made sure it was seated correctly. This is my first cleaning with the new Jandy, but disassembled and reassembled my old Pentair +/- 30 times without any issue. even thinking about lubing the clamp. Any suggestions would be appreciated.
    15K gal,IG Plaster with attached Spa,
    JANDY DE Filter Model DEV 60
    TF-100 Testkit
    City Water - Drain/Re-fill restrictions
    Built in 1979 - re-plastered 2003

  2. Back To Top    #2

    In the Industry

    Join Date
    Apr 2015
    tucson, arizona

    Re: Jandy Dev60 tank clamp

    Did you remove o-ring and clean where o-ring sits. Make sure o-ring is seated properly and it has not flattened out. Also you might tap around clamp as your tightening

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts