Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Polaris 280 not working

  1. Back To Top    #1

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    118

    Polaris 280 not working

    Just noticed leaves in the bottom of my pool. The polaris motor works, and the water is pumped into it, but the polaris wheels are not turning and its barely moving on the bottom of the pool, because its being continuously dragged around by the blob thingy fitted inline. Any ideas what is wrong and part needs to be replaced. Thanks
    15K gal, IG (I think its Vinyl not sure), 2 HP WhisperFlo pump, 60 sqft Pentair DE filter, SWG Hayward Aqua rite controller with t-cell-15, Aqualink RS6, Jandy Spa side 4-button, Polaris 280, 400K Pentair Minimax NT Heater Propane, test kit TF100

  2. Back To Top    #2

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    118

    Re: Polaris 280 not working



    The water gushes put of this continuously dragging the polaris cleaner all over the pool. Preventing it from vacuuming the floor. Something is wrong with it.


    15K gal, IG (I think its Vinyl not sure), 2 HP WhisperFlo pump, 60 sqft Pentair DE filter, SWG Hayward Aqua rite controller with t-cell-15, Aqualink RS6, Jandy Spa side 4-button, Polaris 280, 400K Pentair Minimax NT Heater Propane, test kit TF100

  3. Back To Top    #3

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    946

    Re: Polaris 280 not working

    Amazon.com : Jandy Zodiac G53 Mechanism for G52 : Patio, Lawn Garden, Open up backup jet and check out this mechanism.

  4. Back To Top    #4

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    118

    Polaris 280 not working

    Thanks, i will open and try to fix the mechanism. If i cannot fix it, can i purchase complete replacement kit for backup valve. Its nearly the same price as the mechanism only $49. Amazon.com : Zodiac G52 Back Up Valve Replacement Kit : Lawn And Garden Tool Replacement Parts : Patio, Lawn Garden


    15K gal, IG (I think its Vinyl not sure), 2 HP WhisperFlo pump, 60 sqft Pentair DE filter, SWG Hayward Aqua rite controller with t-cell-15, Aqualink RS6, Jandy Spa side 4-button, Polaris 280, 400K Pentair Minimax NT Heater Propane, test kit TF100

  5. Back To Top    #5

    In the Industry
    Qwaxalot's Avatar
    Join Date
    Jun 2012
    Posts
    439

    Re: Polaris 280 not working

    Better to just replace the valve (G-52)
    In the industry, CSP (Certified Service Professional) by the NSPI and it's successor the APSP. My company services over 600 pools every year. I think the practices regularly espoused on this forum (especially the BBB method) are outstanding; however my comments will be often oriented towards the goal of getting it done, and getting it done right now!

  6. Back To Top    #6

    Join Date
    May 2015
    Location
    Austin, TX
    Posts
    118

    Re: Polaris 280 not working

    I had replaced just the outer shell 5 months ago. I will order the g52, reviews seem good on amazon


    15K gal, IG (I think its Vinyl not sure), 2 HP WhisperFlo pump, 60 sqft Pentair DE filter, SWG Hayward Aqua rite controller with t-cell-15, Aqualink RS6, Jandy Spa side 4-button, Polaris 280, 400K Pentair Minimax NT Heater Propane, test kit TF100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •