Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Sporadic results when turning on jets

  1. Back To Top    #1
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    147

    Sporadic results when turning on jets

    If you've been following any of my posts, I'm new spa owner and having a helluva time with it. I think I have self diagnosed the problem that was causing my breaker to trip as being the heater, because when I disconnect the heater from the circuit board, the breaker doesn't trip and I'm able to circulate water (basically everything else works except the heater).

    As I'm waiting on the technician to come verify/fix my problem, I'm trying to get the water chemistry right. In doing that I'm turning on the jets a lot to circulate when I add chemicals. I have three "Jets" button on the topside controller (Jets 1, Jets 2, Jets 3). When I first got my spa to stay on after disconnecting the heater, all 3 buttons worked and all sets of jets would come on.

    As the days went by, the Jets 3 button stopped working but the other two still did. Next, only Jets 2 worked. Then one day, none of them did! I went and turned the spa off at the breaker and turned it back on a few seconds later. The system primed itself and came back on, but Jets 3 still didn't work. Now sometimes the light on the button itself comes on, but the Jets don't work. It's the craziest thing and its making me wonder if my heater really was the problem and it's actually not the circuit board itself going out. Maybe the heater is fine and it's the circuit board?

    Or could the heater being disconnected cause this because the circuitry expects a heater to be connected?

    Anybody have any thoughts on what could cause the sporadic problem of the jets not working?
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

  2. Back To Top    #2
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Sporadic results when turning on jets

    At this point, it seems like the board may have some issues if you're having multiple problems with pumps operating sporadically. Have you looked into the cost of a replacement board?
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

  3. Back To Top    #3
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    147

    Re: Sporadic results when turning on jets

    Quote Originally Posted by JVTrain View Post
    At this point, it seems like the board may have some issues if you're having multiple problems with pumps operating sporadically. Have you looked into the cost of a replacement board?
    Yes, new board was a couple hundred. Replacing the whole spa pack with heater and board was around $400 I think. I have a home warranty with pool/spa coverage so I'm hoping will cover it as both of these items are clearly listed as something they cover in the contract. But my track record with home warranty companies covering things isn't that good.

    I've been hard pressed to find anyone knowledgeable that works on these type spas in my area. The company it was bought from are the ones that are coming out soon but I'm not exactly holding my breath since me and my electrician had to troubleshoot the problem for them before (after they came and left saying the breaker was bad).
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

  4. Back To Top    #4
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    147

    Re: Sporadic results when turning on jets

    Had a tech come replace my heater so that's now done and it's working. Still having problems with the jets. The tech said the topside control panel needed to be replaced as it was not sending a relay signal to the board. Sound reasonable?

    Some of the buttons have always been really hard to push so maybe that makes sense.
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

  5. Back To Top    #5
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Sporadic results when turning on jets

    Sounds more reasonable. Don't think the top panels are all that costly. DIY likely. Should be easy, just take pictures of wiring before removing old one completely.

    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

  6. Back To Top    #6
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    147

    Re: Sporadic results when turning on jets

    Update on this, I installed a new control panel and everything is working perfectly. Even better, home warranty company is going to pay the full amount for the repairs! Thanks for the replies.
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •