Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Sta-Rite 400NA Heater - suddenly died...

  1. Back To Top    #1

    Join Date
    Aug 2016
    Austin, TX

    Sta-Rite 400NA Heater - suddenly died...

    Hello all,

    I looked through all the old posts but didn't find an answer to my issue. I have a natural gas Sta-Rite 400NA heater. It was working fine but decided to quit out of the blue.

    When I raise the temperature up via remote to activate the heater, the control panel turns on, then it says 128, then r=5, then goes completely blank. I flipped over the top to check the LED' activation they all light up, but then they all go dark. I opened the Ignition Control door to see if there's any fault lights there...also nothing.

    So, I guess my question is: which part do I replace first?

    Is it possible to be something other than the upper control board or the ignition control module?

    Thanks everyone!

  2. Back To Top    #2

    In the Industry
    ps0303's Avatar
    Join Date
    Jul 2011

    Re: Sta-Rite 400NA Heater - suddenly died...

    First thing to do it take it out of remote mode and try and turn it on manually and see what happens. To do this, kill all power to it, shut off breaker. Then you will need to separate the two halves of the unit to get inside. Once inside you will need to open the metal box that contains the wiring. Once inside you should see the two wires that come from your controller unit, remove them and then a jumper wire to connect the two spades clips that the wires were connected to. Once you have done this, power back on the unit and see if the front control panel works like it should.

    A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts