Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Intellipro VS-3050 motor gone after 3 years ?

  1. Back To Top    #1

    Intellipro VS-3050 motor gone after 3 years ?

    Hi
    We had a pool done in Nov 2012, installation included Intelli pro VS-3050 pump. About a year and half after installation the LED screen on the pump went black. Not sure what that part is called but since we purchased 3 pcs of Pentair equipment it was covered under warranty and was replaced free of charge. Fast forward to about a week ago, I hear a loud whirring coming from the pump. Our pool guy says it's the motor. I've had pools before and have never had a motor go out so quickly. Today I got down and looked underneath the motor. See attached photos. Not sure what I"m looking at, but it's all encrusted in something. Not sure if there was a leak where it attaches to the basket part. I have no idea. The pool guy says we should install a new motor at about $500. I'm not sure if I should do that with the way this looks underneath. We do have an Intelliclor Salt generator as well. Is that salt I'm looking at? I'm embarrassed to say I really don't know what the deal is. I'm hoping that someone on here can take a look at these photos and give me a good guess as to what they think may have happened.
    Thanks in advance.
    Carol
    Attached Images Attached Images
    Inground shotcrete, deco & glass tile, 30' x 15', 6 ft depth, 401 sq. ft., Sta-Rite VS3050 pump, 400 Sta-Rite Mod Media Filter, Sta-Rite Max-E-Therm Heater, Intellichlor Salt Chlorinator, PV3 Infloor cleaner, IntelliBrite Led Spa & Pool lights. Quartz - Blue Cayman finish.

  2. Back To Top    #2

    In the Industry

    Join Date
    Jan 2012
    Posts
    340

    Re: Intellipro VS-3050 motor gone after 3 years ?

    Looks like the shaft seal failed, letting water past the housing and back to the motor. I'd say the most common culprit of a failed shaft seal is running the pump dry. It can also happen if lots of sand or abrasive debris is vacuumed through the skimmer.

    Along with replacing the motor, you should consider complete pump replacement. If the drive goes again, you're looking at putting another 600-700 into that pump.
    25K aggregate IG, Intellipro, FNS48, Polaris 360, PG2000 fiber optic light source

  3. Back To Top    #3

    Re: Intellipro VS-3050 motor gone after 3 years ?

    thanks "Poolman" We had someone come take a look today and their suggestion was just as you said. We are replacing the entire unit.
    Inground shotcrete, deco & glass tile, 30' x 15', 6 ft depth, 401 sq. ft., Sta-Rite VS3050 pump, 400 Sta-Rite Mod Media Filter, Sta-Rite Max-E-Therm Heater, Intellichlor Salt Chlorinator, PV3 Infloor cleaner, IntelliBrite Led Spa & Pool lights. Quartz - Blue Cayman finish.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •