Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pentair QuickTouch II wireless remote losing connection.

  1. Back To Top    #1
    LongDuck's Avatar
    Join Date
    Aug 2015
    Phoenix, AZ

    Pentair QuickTouch II wireless remote losing connection.

    Posting this to help others using the Pentair QuickTouch II 4-function remote for their automation system and finding that the remote seems to lose connection to the powercenter on occasion. Symptoms are a remote that lights on button press but won't switch on features and functions even though the powercenter manual controls work fine.

    The first time this happened was during a rainstorm with a quick power outage that had me believing something reset the powercenter, but last weekend it happened while out at the poolside, working one minute and then remote stopped working at random. I called our pool builder who walked me through the Powercenter comm link reset process, which worked handily. This last time took a bit more troubleshooting, but got the job done. Full process steps listed below, and I hope it saves a call-out for someone using this equipment:

    1- at the powercenter is a receiver (looks like a tan remora screwed to a nearby surface) pull up on the remoras "tail" and it will remove the rain cover. Now you can see the circuitboard housing the receiver electronics. On the lower left corner is a tiny blue or white switch which when pushed will reset the receiver encoding to listen for a transmitter. Push that button once, and a small red LED above it will flash three times, signaling that it's now listening. Now, push BOTH bottom buttons on your QuickTouch remote which correspond to Function 4 (both ON and OFF buttons) at the same time and hold them until the remote activation light on the remote flashes three times. Now release the buttons, and push any Function ON. If the function switches on, you're done. If nothing changed, go to step 2.

    2- at the bottom of the circuitboard is a wiring block which has the command control wires screwed into it. This block removes if you pull straight out. Pull the wiring block free from the circuitboard and count to 10 (this kills power to the receiver). Plug it back in and perform Step 1, above. If no-go, try Step 3, below.

    3- unplug the wiring block, and with it unplugged, enter the powercenter Menu - Settings - QuickTouch - Reset Wireless Address, and press the right arrow. This will kill the current address in use, and setup the receiver to listen for a new one. Plug in the wireblock, press the blue or white button, and finish up Step 1, from above. This fixed my connection issue, for now, anyway.

    Caveat: if your system works today - DONT MESS WITH IT! These reset steps are a configuration attempt you can do yourself if you lose wireless connectivity and don't want to call a pool tech to work on it (likely for a fee). If they work for you, great! If not, it didn't break anything because it wasn't working anyway, and I guess your next call will be to your pool builder or pool tech...

    If anyone has any thoughts on how the QuickTouch II interfaces with the powercenter, I'm all ears. I suspect it's some variant of 802.11x based on the antennas and ties to other automation apps. I'm hoping it's just a fluke that this happened twice in as many months, and hoping nobody's hacking into my wireless network and killing my connections.
    July2015 New - 12,900gal IG Clorine Pool: Free Form Shot/PebbleSheen, Ceramic Waterline/Travertine Coping/Deck, Paramount PV3 In-Floor, Pentair 3050VS Intelliflo Variable (3000rpm High/1000rpm Low), Pentair Clean & Clear 420 Cartridge, Venturi Skimmer, MDX/SDX Drain, Paralevel, Rock Waterfall +3/4" Aireator, Intellibrite 5G LED, EasyTouch4, and Tab Floater.

  2. Back To Top    #2

    Join Date
    Jun 2017
    Tucson, az

    Re: Pentair QuickTouch II wireless remote losing connection.

    I've been searching for fixes all day, and thankfully finally stumbled upon this working fix. My receiver LED was solid red and wouldn't make the 3 flashes. Removing the wiring block as instructed in #2 worked like a charm. Thank you so much!!

  3. Back To Top    #3

    Join Date
    Apr 2018

    Re: Pentair QuickTouch II wireless remote losing connection.

    Hi mine is solid green , it's just been installed, and pressing the receiver button , it hasn't flashed 3 times, so I can't go on to next stage of set up.
    Do you think it's a faulty receiver ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts