Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Aqua logic Clock problems --anyone ever figure out anything

  1. Back To Top    #1

    Join Date
    Aug 2016

    Aqua logic Clock problems --anyone ever figure out anything

    I am having the same basic Aqua Logic clock not keeping time that has been mentioned several times on forum. Time fluctuates wildly, not even close, so it throws filter schedule off. I have seen several other threads on this but never saw a solution other than replace board or a mythical 9v battery should be replaced, which mine definitely doesn't have. My chemicals stay in balance and pumps all work just not at correct time, so I hate to pay for a new board but I am getting tired of resetting the clock twice a day. Any ideas?

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Pleasanton, CA

    Re: Aqua logic Clock problems --anyone ever figure out anything

    Welcome to the forum!

    I have never seen a solution. More than likely it is one of the clock components that has gone bad and probably a crystal. You can identify them on the board by X1 and X2 labels on the board. But I don't know of anyone that has tried to replace them.
    Hydraulics 101; Pump Ed 101; Pump and Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater, ThePoolCleaner

  3. Back To Top    #3

    In the Industry

    Join Date
    Jan 2012

    Re: Aqua logic Clock problems --anyone ever figure out anything

    Unfortunately the board needs to be replaced.

    There is no backup battery on the Hayward systems, so mythical is a good description.
    25K aggregate IG, Intellipro, FNS48, Polaris 360, PG2000 fiber optic light source

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts