Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Problem with the quick connection of a Polaris 380 robot

  1. Back To Top    #1

    Join Date
    Aug 2016
    Location
    Jacksonville FL
    Posts
    1

    Problem with the quick connection of a Polaris 380 robot

    Hi all,

    I have just bought a house and cleaned the pool. I am a novice in pool taking care of. I have a Polaris robot. My problem is that when I plug it in the pool the quick connection is not staying, it doesn't stick to it due to the pressure of the jet. There seems to be no problem with the plug itself, it doesn't seem to be broken at all. The Robot seems to be in pretty good shape.

    Anyone would see where the problem could come from? Thanks in advance for your advices.


    Marc

  2. Back To Top    #2

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    946

    Re: Problem with the quick connection of a Polaris 380 robot

    This has a quick disconnect that is pushed in and turned clockwise to lock in, pull on it to see if its secure. If this doesn't work unscrew fitting in wall and check to see if there are two little nubs sticking out that accept the disconnect

  3. Back To Top    #3

    Join Date
    Jul 2016
    Location
    East TN
    Posts
    45

    Re: Problem with the quick connection of a Polaris 380 robot

    As a side note to kadavis, you could turn off the pump when trying to plug it into the return port. It can be troublesome to do it with all that pressure coming out.
    18x36 8ft deep end (~27k gallons), IG, Vinyl Lined, Polaris 360 Cleaner
    Sand filter, 2HP Pump, Municipal Water Source TF-100 Test kit
    East TN
    CYA Chart SLaM Add DE to Sand OCLT

  4. Back To Top    #4
    Mod Squad YippeeSkippy's Avatar
    Join Date
    Jan 2012
    Location
    'burbs of Augusta, Georgia
    Posts
    6,491

    Re: Problem with the quick connection of a Polaris 380 robot

    We use a Polaris quick connect wall fitting and learned you can't really trust the connection if you try to put it on while the pump's running. Gotta turn that pump off to get the fitting to click in place. Sorry!
    My Amazon Smile for November12K Fiberglass IG, Infinity 4000 automatic cover, SWCG, Hayward Sand Filter, Hayward 1.5 Pump, Doheny Discovery Robot, Savi Melody LED pool lights, outdoor speakers and other assorted doo-dads. Sundance Altamar Hot Tub.
    Our pool build--> Our Pool Solved Our Sloping Yard Skippy's Cheap Pool Cooler -->Skippy's New Fountain

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •