Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: IntelliChlor IC60 Keeps Blowing Fuse

  1. Back To Top    #1

    Join Date
    Aug 2016
    Location
    Cincinnati
    Posts
    1

    IntelliChlor IC60 Keeps Blowing Fuse

    My IntelliChlor IC60 blew it's fuse today, it had a 10 amp 250V fuse in it previously. I couldn't find a slow blow fuse so I settled with using a 10 amp 250V fast-acting fuse as a replacement which it immediately blew once turned on. I tried another fast-acting 10 amp which it also blew. The cell just entered it's second year and I have it serviced regularly. I've seen some talk here (Pentair Power Cell Fuse) that the IC60 should be using a 12 amp fuse and not a 10 amp. So what I'm wondering is it blowing fuses because I tried using the wrong fuse or is it a bigger problem with the cell itself? I've seen an alarming number of people who are complaining about fuses being blown similar to the issue I've been experiencing and was wondering if it is a known wide spread issue with newer IntelliChlors? Also would anyone happen to know where I can get the right fuse for the IC60?

    Any help or advice would be greatly appreciated.
    40,00 gallon in ground vinyl pool
    Intellichlor IC60

  2. Back To Top    #2

    In the Industry

    Join Date
    Jan 2012
    Posts
    340

    Re: IntelliChlor IC60 Keeps Blowing Fuse

    IC60 is not big in my area, but we manage three pools that we have installed IC60 on using standard power center/fuse setup with no issues. Your cell probably has an issue. I would call Pentair before installing a 12 amp fuse. 10 amp is what comes in the power center and what they sell as a replacement for all IC20, IC40, and IC60.
    25K aggregate IG, Intellipro, FNS48, Polaris 360, PG2000 fiber optic light source

  3. Back To Top    #3

    Join Date
    Jul 2015
    Location
    Dayton/Maryland
    Posts
    83

    Re: IntelliChlor IC60 Keeps Blowing Fuse

    I had an IC40 which kept blowing fuses. Finally I figured out it is time to replace the IC40 cell. Once I replaced a new IC40 cell, there is no fuse blowing.


    Quote Originally Posted by Why View Post
    My IntelliChlor IC60 blew it's fuse today, it had a 10 amp 250V fuse in it previously. I couldn't find a slow blow fuse so I settled with using a 10 amp 250V fast-acting fuse as a replacement which it immediately blew once turned on. I tried another fast-acting 10 amp which it also blew. The cell just entered it's second year and I have it serviced regularly. I've seen some talk here (Pentair Power Cell Fuse) that the IC60 should be using a 12 amp fuse and not a 10 amp. So what I'm wondering is it blowing fuses because I tried using the wrong fuse or is it a bigger problem with the cell itself? I've seen an alarming number of people who are complaining about fuses being blown similar to the issue I've been experiencing and was wondering if it is a known wide spread issue with newer IntelliChlors? Also would anyone happen to know where I can get the right fuse for the IC60?

    Any help or advice would be greatly appreciated.
    2003 Build 20K gallon salt water gunite IG pool, Taylor 2006 test kit, Pentair 011018 IntelliFlo Variable Speed Pump, Pentair IntelliChlor IC40 SWG, Aquabot ABTTJET Turbo T Jet Robot

  4. Back To Top    #4
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    5,290

    Re: IntelliChlor IC60 Keeps Blowing Fuse

    Why,

    Pentair puts in a slow-blow fuse for a reason. The in-rush current when you first turn the unit on may be high for a brief moment, and they don't want the fuse to react (blow) during that time. If this were my unit, I'd replace the 10 amp fuse with a 12 amp slow-blow fuse and try it again. My gut feeling is that the IC60 is bad and will blow the 12 amp fuse just as soon as you turn it on. If it works, having a 12 amp fuse will not have any impact on the safety of the circuit. There is just not that much difference between the two fuses.

    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Calder Spa.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •