Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pentair IC40 Low Salt Reading

  1. Back To Top    #1
    Otis Campbell's Avatar
    Join Date
    Mar 2013
    Lewisville, TX

    Pentair IC40 Low Salt Reading

    I have a similar issue as described in old thread. The conclusion in that thread was that the SWG was bad and Pentair replaced it.

    Some days my SWG reads 3300 - 3400 other days it reads zero. This has been going on for a few weeks. One time I got the zero reading the day after I added 40 pounds of salt. Last weekend I took a water sample to a nearby pool store. He uses a Taylor test kit for everything but salt. For salt he has some fancy $500 machine. Anyway, he got 3250 for salt and I was getting 3300 from the IC 40 that day.

    So I called my PB (I'm about 30 days from my 3 year warranty running out) and told them that my SWG is acting up and warranty needs to come out and replace it. Their theory is that the SWG and the DE filter need to be cleaned. I've never cleaned my filter although I backwash every month. I haven't cleaned the SWG although I inspect it periodically and have never seen any signs of build up. They are coming out next Tuesday to clean the SWG and the filter. I generally trust my PB but I'm suspicious of this diagnosis, primarily because I've read so many threads that describe what I'm experiencing and the solution was a new SWG.

    I've got time to watch the SWG for a few weeks after they do this cleaning for me. So if it doesn't fix the issue I should be able to get the SWG replaced under the warranty. Just curious on opinions about the diagnosis.
    Inground Gunite, plaster surface. 28,000 gallons, modified L shape with diving area and play area, attached spa, all pentair equipment, SWG, variable speed, DE Filter, Nature 2 Express. Taylor 2006 test kit.
    Why should you become a Lifetime Supporter of TFP? Because the first time you have a problem and you get the solution at TFP you will recoup your cost many times over.

  2. Back To Top    #2
    JoyfulNoise's Avatar
    Join Date
    May 2015
    Tucson, AZ

    Re: Pentair IC40 Low Salt Reading

    The IC SWG's have an internal temperature sensor which can sometimes go bad. If it does, the system is supposed to default to a temperature of 75F and compensate from that point. Because of this sensor failure, the salinity level can be pretty far off from the actual value. Generally speaking, Pentair ICs have really bad temperature compensation to begin with, so the salinity read-out is sketchy at best. To add further insult, Pentair only reports the internal diagnostic values (including the readout from this temperature probe) when one uses a device called an IntelliWand; it's a device that hooks up to a laptop USB port and communicates with the IC through a proprietary RF signal. It's really frustrating because the IntellWand costs ~$150 and few PB's or Pool Stores will have them, so there's no way to access the internal diagnostics of the unit without it leaving the person to guess at what the problems might be. Although I really like Pentair equipment, this one issue is really a black-eye on them because they could make those diagnostics available fairly easily and save people a lot of hassle.

    If your PB is willing to get you a new IC, that would be great. Other than that, all you can do is make sure the cell is clean, that there are no low/high salt error lights on and that it is indeed generating sufficient FC levels.

    And yes, the diagnosis by the PB is bogus. The cleanliness of your filter has nothing to do with it. But I would say this - you should be tearing down and cleaning your DE filter once per year. Backwashing is really not the best way to go. In fact, I have completely abandoned backwashing all together and I just tear down and clean my DE filter twice per year. In doing so, I save on DE costs by only using two 10lbs bags of DE per year and I never have to guess at how much to charge a filter up with. When you backwash, you remove less than 50% of the DE so if you are using the full charge weight of DE with every backwash, your filter is going to be overcharged with DE and that impacts flow and cleanliness.
    16k IG PebbleTec pool, 650gal spa, spillway and waterfall, 3HP IntelliFlo VS / 1.5HP WhisperFlo, Pentair QuadDE-100 filter, IC40 SWCG, MasterTemp 400k BTU/hr NG heater, KreepyKrauly suction-side cleaner, EasyTouch controls, city water, K-1001, K-2006 and K-1766 test kits, Mannitol test for borates

  3. Back To Top    #3

    TFP Guide
    Jimrahbe's Avatar
    Join Date
    Jul 2014
    Bedford, TX

    Re: Pentair IC40 Low Salt Reading


    I had a very similar problem with my IC40 earlier this year, although this is just the second season. The salt reading on my ScreenLogic Display kept going down. At first I added more salt thinking "if the SWG is happy, I'm happy", but after a while I realized something was wrong. When I used the Taylor Salt Test kit the salt was at the upper limit not the lower limit as the IC40 reported.

    Called my PB and they sent out a Pentair tech, who replaced the Flow Switch/Temperature Sensor unit. That was all it took, the IC40 now reports the correct salt readings.

    I suspect they will do the same for you under warranty, but if for some reason they don't, you can buy a new assembly for around $100 and install it yourself.


    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP5200 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts