Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: slight squeal - hayward super pump

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Marietta, GA
    Posts
    95

    slight squeal - hayward super pump

    I have a Hayward Super Pump. The pump itself is older, but I replaced the motor shortly after I bought the house (about 3 years ago), with a new AO Smith. Before the first motor quit, the pump was kinda loud like a higher pitch sound. After I replaced the motor, I was suprised at how quiet the pump was. So fast forward to about a week ago, I noticed the same kinda sound. I thought maybe some debri was lodged around the impeller, so I took the motor off, and removed the impeller. There was a lot of moisture behind the seal, and a bunch of corrosion. Can someone take a look at these pictures and tell me if this is normal? Also, when I looked inside the metal "vents" at the top of the motor, I saw a dead lizard. I am not sure there is an easy way to get in there and remove it, or if it matters. Also the impeller was very easy to remove. I held the nut in back of motor, and did not have to use any force to loosen the impeller.

    Lastly, I had a pinhole leak in the pump housing, which I patched with JB Weld, and that held perfectly until the other day I noticed very small amount of water leaking from under the JB Weld, so I cut away a bit of the mateial that was loose, and appliend more to seal it. Now no more leak, but not sure how long it was leaking.
    lizard.jpgmotor_top.jpgimpeller.jpgleak.jpg

    So, any guidance on next steps would be appriciated. The algea is back, and need to get this pump back in asap. Thanks!

    Chris
    27k gal, IG vinyl, Pentair Triton II Sand Filter, 1 HP Hayward Super Pump, Liner 3 yrs old, Intermatic PF1103T Timer w/ Freeze Protection, K-2006.

  2. Back To Top    #2

    Join Date
    Jun 2014
    Location
    Marietta, GA
    Posts
    95

    Re: slight squeal - hayward super pump

    I just noticed a crack on the impeller. Not sure if this is related to my problem, but that may explain why it was so easy to remove. Do I need a new one? Here is the photo...impeller_crack.jpg
    27k gal, IG vinyl, Pentair Triton II Sand Filter, 1 HP Hayward Super Pump, Liner 3 yrs old, Intermatic PF1103T Timer w/ Freeze Protection, K-2006.

  3. Back To Top    #3

    Join Date
    Jun 2014
    Location
    Marietta, GA
    Posts
    95

    Re: slight squeal - hayward super pump

    So I watched a few videos I found in other posts, and ended up cleaning all the corrosion with a steel brush. Then I replaced the impeller and the porcelain rubber seal thing. Put it all back together, and motor still sounds like it has kind of a mechanical echoing sound. Not sure if the cracked impeller had anything to do with this issue, but given that crack I figured it needed to be replaced anyway. Since water got in the motor, I am wondering what it sounds like when the bearings are going bad. If anyone has a link to a recording of that, let me know. I mean the sound is not loud or anything, but it is more noticable than several weeks ago. Any guidance would be appreciated. Thx.
    27k gal, IG vinyl, Pentair Triton II Sand Filter, 1 HP Hayward Super Pump, Liner 3 yrs old, Intermatic PF1103T Timer w/ Freeze Protection, K-2006.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •