Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Jandy RS controller question?

  1. Back To Top    #1

    Join Date
    Apr 2016
    san diego, ca

    Question Jandy RS controller question?

    Hi all...
    I needed to clean my 1400 cell, so I shut the power off to my Jandy RS Power Center (at the circuit breaker).
    After reinstalling the cell, I turned the circuit breaker back on.
    Normally, after restarting the Power Center, all the red indicators lights on the panel flash from one side to the other - and the system resumes normal operation.
    However, this time, after turning the power back on - nothing happened.
    I waited around a minute and the "valves" red light (on the right side of the panel) flashed quickly one time, and then the "auto" red light (on the left side of the panel) flashed twice.
    It kept doing this every minute, and nothing happened after well over 15 minutes - no power, nothing.
    I also tried pushing in the "reset" button on the panel, and the panel flashed the same lights after I let of the rest button.
    I tried shutting the system completely off (thinking the mother board may reset itself), but no luck.
    I checked the transformer, and it has power in and 24 volt power out. I checked the small glass fuse and it was ok.
    Anyone have any idea what the issue might be?
    Any help would be GREATLY appreciated!

  2. Back To Top    #2

    In the Industry

    Join Date
    Apr 2015
    tucson, arizona

    Re: Jandy RS controller question?

    If you have a older model with backup 9 volt battery try turning off power and then disconnect battery for a few minutes. Reconnect battery and turn power back on. If you have 24-28 volts on transformer and fuse is okay you may have a bad board. You might call Jandy and see if they have something else you can try

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts