Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Polaris 825 Not moving/Cleaning

  1. Back To Top    #1

    Join Date
    Aug 2016
    Location
    Laredo, TX
    Posts
    1

    Polaris 825 Not moving/Cleaning

    Hello everyone,

    I have the 825, I have had it for two months. Tonight, while it was cleaning the pool; the p825 stopped and turned off (after 2 hours of cleaning which it did a decent job of). So I turned it back on, so it can come up the pool wall so I could pick it up and clean the filter and it would not move. I tried repeatedly; so I had to jump in the pool to pick it up out the water. I cleaned out the filter with a water hose and put it back in the pool. From what I saw, the cleaning portion would work but the wheels of it don't actually move so it stays in the same spot. I am not to sure what happened; this has never happened..for $900.. this should not break after 2 months of use. I tried turning it off a few times and turning back on; it looks like its cleaning (barely) but it is not actually moving. Has anyone seen this happen?

    Are there any troubleshooting steps for this?

    Thanks for your help.

  2. Back To Top    #2

    Join Date
    May 2016
    Location
    Schwenksville, Pa
    Posts
    3

    Re: Polaris 825 Not moving/Cleaning

    You may have to take it apart and use a toothpick to clean out small debris in the jets near the wheels. I have a Polaris and have to do this once or twice a season if anything gets by the screen in the hose.
    Plaster 40,000 gal in-ground with hottub
    Pool Pilot Digital / heated

  3. Back To Top    #3

    Join Date
    Aug 2016
    Location
    Orange, TX
    Posts
    1

    Re: Polaris 825 Not moving/Cleaning

    My 825 started doing the same thing yesterday. I've only used it about 6 times. Have you figured out what was wrong with yours?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •