Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Jandy Aqualink RS Motherboard gone bad

  1. Back To Top    #1

    Join Date
    Aug 2016
    Location
    Lewisville, TX
    Posts
    3

    Jandy Aqualink RS Motherboard gone bad

    Hey everybody. I am new to this so forgive me if I am posting incorrectly. Sunday, the pool was working fine. Woke up on Monday morning and the pump wouldn't turn on. Went out to the Aqualink box by the pool equipment and all the lights were on. Nothing was functional. I turned off the breaker and turned back on the breaker, but nothing happened. I googled and read to turn off the breaker, remove the 9V battery, then turn back on the power to see if it turns back on. Nothing happened. I also read to try all that, but before turning the power back on to hit the reset button. That did nothing. The PDA won't connect to the unit. It only says "Waiting". I talked to a pool guy friend and he said it sounds like my board has gone to a motherboard heaven.

    I hardwired my pump so I can at least run the pump until I get this fixed but I wanted to see if anybody had any other ideas of how to fix it. Or if they knew anyone in the Dallas, TX area that repairs motherboards. If no other ideas on how to fix it, does anybody know where I can get a replacement motherboard for the Aqualink RS PDA? Everything I have found seems to be a PDA conversion kit for $800-900. I just want to get it fixed ASAP and get my pool back to normal. I don't want to walk out to the equipment to flip a switch every morning to turn on the pump and currently, I don't have the sweeper wired so that is non-functional. Any advice is greatly appreciated. Thanks everybody.
    18K gal IG, gunite pebble tec, chlorine, 2 HP Pentair Challenger Pump, 1.5 HP Pentair Challenger Pump for sweeper, 3/4 HP Pentair Booster Pump for waterfall, 60 sqft DE filter, Aqualink RS PDA control, Polaris sweeper

  2. Back To Top    #2

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    943

    Re: Jandy Aqualink RS Motherboard gone bad

    http://www.bpelectronics.com/ Go to this website they may help. First you must determine the board is bad, because replacing is going to be
    $700-800 dollars. Jandy is bundling there new board w/PDA and iaqualink systems so the board is cheaper

  3. Back To Top    #3

    In the Industry

    Join Date
    Jan 2012
    Posts
    340

    Re: Jandy Aqualink RS Motherboard gone bad

    Ditch the PDA and go iaqualink.
    25K aggregate IG, Intellipro, FNS48, Polaris 360, PG2000 fiber optic light source

  4. Back To Top    #4

    Join Date
    Aug 2016
    Location
    Lewisville, TX
    Posts
    3

    Re: Jandy Aqualink RS Motherboard gone bad

    That was my initial game plan but I've read and heard bad things about the iaqualink. I read a lot of people are having trouble with it hooking up to their wifi and the only solution is to run a wired internet connection to it. Our modem is at the front right corner of the house and the j box is at the back left corner of the backyard. Idk if the wifi would reach that far and if it wouldn't I sure wouldn't want to run a line that far. Have you heard of any problems with the iaqualink regarding connectivity?
    18K gal IG, gunite pebble tec, chlorine, 2 HP Pentair Challenger Pump, 1.5 HP Pentair Challenger Pump for sweeper, 3/4 HP Pentair Booster Pump for waterfall, 60 sqft DE filter, Aqualink RS PDA control, Polaris sweeper

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •