Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Aquarite "Inspect Cell" light constant

  1. Back To Top    #1

    Join Date
    Aug 2016
    Location
    NASHVILLE TENNESSEE
    Posts
    2

    Aquarite "Inspect Cell" light constant

    I maintain a 62,500 gallon saltwater pool. Recently, the "inspect cell" light on the Aquarite came on and stayed on along with the "check salt" light. The manual says this indicates low salt. I added salt and later attempted to reset to display the actual salt ppm. Nothing changed and the reading went back to 1600-1800ppm. This pump has two T-15 cells. I had the salt level checked by a pool company which read it at 3400 ppm. Chlorine and other levels are fine at the moment. There is also a Pentair automatic chlorine off-line feeder connected to the system.

    This morning, I removed both cells and cleaned them. I also installed a new filter for the pump and the flow rate is very good. I believe these cells have a 3 year warranty but they were purchased before I got here and I am skeptical that anyone has receipts. This particular pump runs 24/7/365.

    Hoped someone might have some suggestions before I consider buying two more expensive cells!
    Patrick
    62500 in ground
    saltwater

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,489

    Re: Aquarite "Inspect Cell" light constant

    Welcome to the forum!

    Have the cells tested. Those are symptoms of a failing cell. Are both cells alarming?
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  3. Back To Top    #3

    Join Date
    Aug 2016
    Location
    NASHVILLE TENNESSEE
    Posts
    2

    Re: Aquarite "Inspect Cell" light constant

    Quote Originally Posted by mas985 View Post
    Welcome to the forum!

    Have the cells tested. Those are symptoms of a failing cell. Are both cells alarming?
    Difficult to have the cells tested as this pool is in a condo complex and open during normal business hours. Both cells are alarming. BTW, was on the phone this morning with a tech from Hayward. Ran all of the diagnostics and amperage very low considering water temp for both cells. Learned also that the cells are apparently over 3 years old. Looks like I will have to invest in some new ones. Any thought as to buying generic if available versus the expensive Hayward t-15?

    Thank you SO much.
    Patrick
    62500 in ground
    saltwater

  4. Back To Top    #4
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,489

    Re: Aquarite "Inspect Cell" light constant

    Any thought as to buying generic if available versus the expensive Hayward t-15?
    I wouldn't. They don't seem to last as long and the price difference is not all that much.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •