Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: What could it be?

  1. Back To Top    #1

    Join Date
    Mar 2016
    Location
    Pittsburgh, PA
    Posts
    51

    What could it be?

    I've noticed a change with my pump over the last 10 days or so. Normally, the water level in the pump basket is right up against the glass lid. It was so full, that without an occasional piece of debris floating by, it almost appeared as if there was no water in it at all. It had been that way for years. Now however, it appears that the basket is not quite filling and there is a lot of sloshing. As I said, this is very out of the ordinary. The water level is still well above the intake into the pump, so no air is getting into the pump that I can tell, and the pump doesn't sound any different than before. I checked the impeller, which was clean. I checked for any side suction leaks and couldn't find anything. No bubbles being discharged into the pool. The skimmer and floor drains seem to be functioning as normal, though its hard to compare suction levels from before. Everything seems normal except the water level in the pump basket.

    What am I missing? Could my pump be heading south? Could there be a clog somewhere in the underground piping? How do I check / fix it?

    Any advice is greatly appreciated. Thanks!


    15 x 35 rectangle inground, vinyl liner, 3' to 7', Jandy 'Stealth' 1.5 hp pump, Hayward cart. filter with chlorinator (not used), 1 skimmer, 2 bottom drains, 2 outlets back into the pool, Heatsyphon heater, Poolcover automatic cover.

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: What could it be?

    Welcome to TFP!

    Sounds like a suction leak. The o-ring on the basket lid is the most common culprit.
    More here, Pool School - Suction Side Air Leaks
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    Join Date
    Mar 2016
    Location
    Pittsburgh, PA
    Posts
    51

    Re: What could it be?

    Thanks for the welcome, though I've been reading the forums for a while now...just never posted.

    Before posting, I did double check the basket lid, and even did the water test. Tight as a drum. I also noticed that the filter pressure crept up a just a little. Not sure if its a related symptom or not. Lastly, when opening the air release knob on top of the filter, I immediately get water...No air building up in the filter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •