Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Pump won't prime

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Windham, NH
    Posts
    49

    Pump won't prime

    Need some help trying to figure out issue with pump. It was working great and had no issue priming with a really strong return. Now the pump won't prime, but the return is still really strong with a lot of air bubbles coming out of the return with the strong current. The water level doesn't seem low but adding water anyway just incase, but still not priming even after more water has been added. I tried backwashing and tried turning pump off and then on again.

    Suggestions?
    13,541k g, AG, SHarkline Heritage 24', Hydromax AC DE95 Filter, Vinyl

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,489

    Re: Pump won't prime

    If the pump is pushing water out the returns, then technically, it is primed. However, if you have air in the pump basket, that could just be an air leak. Check the pump lid and drain plug gaskets for cracks. Try lubing them.

    Also, while the pump is running, look inside the skimmer and see if any air is being sucked in from there.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  3. Back To Top    #3

    Join Date
    Jul 2015
    Location
    Windham, NH
    Posts
    49

    Re: Pump won't prime

    The skimmer is sucking water in so fast it's created a vortex with a lot of air and water going in at once. So you think it could be an air leak in the pump basket?
    13,541k g, AG, SHarkline Heritage 24', Hydromax AC DE95 Filter, Vinyl

  4. Back To Top    #4

    Join Date
    Dec 2014
    Location
    Santa Ana, CA
    Posts
    523

    Re: Pump won't prime

    water level in the pool still too low? Mine does that in such case.
    44k plaster pool, Pentair 011018 pump, DE6020 filter, LED lights, K2006 test kit

  5. Back To Top    #5
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,489

    Re: Pump won't prime

    Yes, the water level is too low.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  6. Back To Top    #6

    Join Date
    Jul 2015
    Location
    Windham, NH
    Posts
    49

    Re: Pump won't prime

    ok, thanks! I'll keep adding water. Appreciate your responses!
    13,541k g, AG, SHarkline Heritage 24', Hydromax AC DE95 Filter, Vinyl

  7. Back To Top    #7
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Pump won't prime

    You could also try adding a rock or something in your skimmer to try to break up the vortex ... after adding more water of course.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  8. Back To Top    #8

    Join Date
    Jul 2015
    Location
    Windham, NH
    Posts
    49

    Re: Pump won't prime

    Ooh, great idea! Thanks!
    13,541k g, AG, SHarkline Heritage 24', Hydromax AC DE95 Filter, Vinyl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •