Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: IC 40 Flow light delay

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Nj
    Posts
    12

    IC 40 Flow light delay

    Recently I noticed that the flow light is slow to turn from red to green when the pump turns on. Returns show strong flow and filter pressure is 5psi over initial charge with DE. When the pump turns off the flow light stays green for some time despite no flow. I washed out the cell with a hose and also did a muriatic acid wash this morning hoping this will fix it. Any other recs? We are 1 yr into a 3 yr warranty

  2. Back To Top    #2

    Join Date
    Oct 2015
    Location
    Burleson, Texas
    Posts
    178

    IC 40 Flow light delay

    I just had my IC 40 replaced after 8 months under warranty due to a bad flow switch. My builder put in the warranty ticket and they were out the next business day.


    21,000 gallons, Salt, IG Gunite, Plaster Finish, Free From, Pentair FNS DE cartridge filter, Pentair Intelliflo-VS pump, Intellichlor IC-40, 2 port fountains, bubbler in tanning deck, Dolphin M400, TF-100, K-1766, Speed Stir

  3. Back To Top    #3
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: IC 40 Flow light delay

    Sounds like a little bit of a built in delay in the circuit. I've never noticed it but it sounds pretty normal to me. Why is it a problem that needs to be fixed?

    Be cautious with washing the cell with MA, each time you do reduces the life of the cell a bit. Especially if you wash it when there is no scale present. Only wash the cell with MA when scale is present. I have not washed my cell in 5 swim seasons.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  4. Back To Top    #4

    Join Date
    Jun 2014
    Location
    Nj
    Posts
    12

    Re: IC 40 Flow light delay

    The flow light stayed green despite no flow. They're replacing the sensor under warranty.

  5. Back To Top    #5

    Join Date
    Jun 2014
    Location
    Nj
    Posts
    12

    Re: IC 40 Flow light delay

    Just an update. They ended up replacing the entire cell.

  6. Back To Top    #6

    Join Date
    May 2016
    Location
    Tallahassee
    Posts
    71

    Re: IC 40 Flow light delay

    Mine did the same thing....I pulled the flow tab out a bit and it fixed it....but I have my swg wired to switch off whenever the pump is off so the flow switch is not important to me anymore....
    20k Gunite 16' x 32' , Hayward c7030 700 sq ft cartridge filter. Pentair Superflo 1hp 2sp pump, Intellichlor IC40 w/ Power Center SWG, Hayward GL-235 Solar Controller, (2) Digital GE Timers.

  7. Back To Top    #7

    Join Date
    Jan 2015
    Location
    Anthem, AZ
    Posts
    178

    Re: IC 40 Flow light delay

    be careful. those things can turn into an issue that could explode. there is a key word i wanted to avoid in a forum post, but you get the idea.
    19K IG Pebbletec with attached spa. 60sqft Cartridge filter, Intelliflow VS, 399k BTU Gas Heater, Pentair IC40. Phoenix, AZ, full sun.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •