Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Backwash hose flows before priming on FILTER mode, sucks air after shutting off

  1. Back To Top    #1

    Join Date
    Jul 2016
    Location
    Scottsdale
    Posts
    1

    Backwash hose flows before priming on FILTER mode, sucks air after shutting off

    I am having major priming issues that I can't overcome, and I need help. Please! I have a DE Filter with a Pac Fab / Pentair multiport valve - like the Hi Flow model.

    Something strange is going on with the multiport valve that I want to share. When I turn the pool motor on (and there is never any water in the pump basket), water flows very slowly into the pump basket. For some reason, the backwash hose leaks at this point (not dripping - faster than dripping) pool water. After two minutes or so pass and the pump primes, the backwash valve stops leaking.

    Then, when I shut the pump off, the pump basket empties itself of water very quickly, while the backwash hose (made of hard PVC) is sucking air. When I cover the backwash hose with my hand, I feel quite a bit of suction.

    I have had major priming issues for some time, and can't seem to solve this. Any suggestions?

    Thank you for much for helping me try and figure this out!

    Marc

  2. Back To Top    #2

    TFP Guide
    BattleOfYakima's Avatar
    Join Date
    Apr 2016
    Location
    Central Florida
    Posts
    1,333

    Re: Backwash hose flows before priming on FILTER mode, sucks air after shutting off

    Questions for markymarc2u:
    1. Was it always like this? You mentioned it's been this way for a while, but always?
    2. The return eyes in the pool (where the water reenters the pool from pump/filter) - are there little bubbles with the water that comes back?
    3. Does the plumbing have a hookup for a pool sweep robot? Like an extra pvc pipe in the pool that you don't use?
    4. Does your plumbing have a booster pump?

    Thoughts for people more expert than me:
    spider gasket? need of a check valve? basket o ring? Air leak in any existing valves?
    If I was effective, and your pool makes you smile, please make me smile and CLICK HERE to Become a TFP Supporter!
    Also, please make AmazonSmile donate to TFP by CLICKING HERE, at no cost to you!
    My Florida Pool: 20k IG plaster cart K-2006 | Washington State Pool I help with: 17k AG vinyl sand TF-100

  3. Back To Top    #3

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,083

    Re: Backwash hose flows before priming on FILTER mode, sucks air after shutting off

    Open up the multiport and examine the spider gasket. I think your problem is there.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •