Become a TFP Supporter Pool Math Forum Rules Pool School
Page 1 of 2 12 LastLast
Results 1 to 20 of 28

Thread: Pump not getting full

  1. Back To Top    #1

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Pump not getting full

    I have a primary pump (Pentair Whisperflo, WFE-4) that is used for the filtration system, I have a secondary pump (Hayward SP2815X20) that is used for the blower and the jets in the Jacuzzi, I have holes on the floor of the jacuzzi and jets on the wall, I can control this pump and both jets from an air switch in the jacuzzi. I recently noticed that only the floor bubbles were working, the wall jets were not pushing anything out. So I looked at the Hayward pump and there was no water in the basket, i also noticed that it was sucking in air. I remove the cover and notice the gasket/0-ring was old and cracked. I went and bought a new one, lubed it and installed it, the wall jets started working again, but the water level in the pump is very low. On the cover it says to fill with water before starting the pump, but when I fill it with water the water disappears. It seems like its going into the pump????? So I cant really "fill it up" with water. After putting it back together and turning it on, its the same thing, the jets work but the water level is very low. There's no valves or anything for this pump, only on the main pump. Is there any where I can force water into the pump?











    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Pump not getting full

    Bottom line is you still have an air leak somewhere. Try lubing the pump drain plug gaskets. Also, make sure the impeller inlet under the pump basket is free from debris.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  3. Back To Top    #3

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    Ok, will start there.....

    Would it be a good idea to get this:

    Amazon.com: Hayward SPX1600TRA Seal Assembly Replacement Kit for Hayward Superpump and MaxFlo Pump: Patio, Lawn Garden


    I should also mention the bearings are making a "clunky" noise for lack of a better term, so I'm assuming I should replace both of them if I move forward......

    Hayward Max-Flo II SP2815X20 Pump Parts | Pump Repair Supply


    So technically, sounds like this pump requires a rebuild?
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  4. Back To Top    #4
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Pump not getting full

    The seal kit has nothing to do with an air leak. That prevents water from leaking out after the impeller.

    Air leaking in is caused by a suction side air leak from the pump basket towards the skimmers/MDs.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  5. Back To Top    #5

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    Ok, this setup is still new to me, I bought this house 8 months ago.......How do I figure out where the air leak is at?
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  6. Back To Top    #6
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Pump not getting full

    Did you lube the pump drain plugs? They are at the bottom of the pump basket on the outside.

    If that doesn't work, look around the pump basket area for any cracks that might be in there. Also, even though you replace the lid gasket, it may not have fixed the entire problem. Check to see if the lid is warped at all.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  7. Back To Top    #7

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    Got it!

    I will do all of that tonight and report back.

    Thanks!
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  8. Back To Top    #8

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    So, there's no o-ring on either plug. What I'm also trying to figure out is where is the water supposed to be pulling from?
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  9. Back To Top    #9
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Pump not getting full

    Without the gasket, the drain plugs will leak air into the pump basket. Try and replace those.

    The spa pump usually draws from the spa floor drains.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  10. Back To Top    #10

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    Ok. Gonna see if a couple local places have them, it's weird because I stuck a hose in the pipe where the water should be coming from and I didn't see any water coming from the spa floor drain.
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  11. Back To Top    #11

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    Shouldn't there have been water coming out of the floor drain when I placed the garden hose in the pipe bringing water into the pump?
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  12. Back To Top    #12
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Pump not getting full

    Yes but how do you know it wasn't? I doubt there is another suction port in the spa. If you keep the hose running in the pipe, the spa should eventually overflow into the pool.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  13. Back To Top    #13

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    That's what I was trying to gauge, but the water level didn't seem t change. Also, even if there is a air leak the jets still come on, the basket just doesn't get full of water and it seems that the previous owner didnt replace the correct basket.
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  14. Back To Top    #14
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Pump not getting full

    It takes quite a while for a hose to make a noticeable difference in water level. It has to be going into the pool, spa or overflow the basket. What are you trying to solve with the hose experiment? I am confused on that.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  15. Back To Top    #15

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    This house is still new to me (8 months), I'm just trying to fully understand all the plumbing, so by placing the hose in the pipe, I was trying to figure out where the water is pulled from for this pump by kind of reversing the water flow to see where it comes out of.

    Also, how imperative is it for the pump to have the correct basket? The basket installed was way shorter than the basket it should have.
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  16. Back To Top    #16
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Pump not getting full

    I think the worst it might do is let some debris past it. But, if it is tight around the top then it should be OK.

    How about a little food coloring in the basket and then the hose, maybe that will show up on the other end.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  17. Back To Top    #17

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    Ok!

    I will try that!!!

    At lunch I visited a mom n pop type of pool place because they had the correct basket and I was telling the guy my issue and he told me that my model of pump plugs dont have o-rings???? He even had a similar model that he was working on and showed me that it had no o-rings.

    He was actually amazed that my spa did not have 2 floor drains and was trying to figure out where the Hayward pump is pulling from, after looking at my pics on my phone, he felt that they T'd off one of the lines circled in black........So, he thinks if I move the valve in red to the middle, water should divert into the pipe for the Hayward pump (circled in yellow)





    Any thoughts on that theory?
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  18. Back To Top    #18
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Pump not getting full

    So it always pulls from the pool? That would be crazy. The spa would constantly overflow if it was setup that way an you could never heat up the spa.

    You have no floor drains in the spa? Nothing else that looks like a suction port or skimmer in the spa? If in doubt take a picture. It could be on the spa wall near your feet.

    If the pump does not have gaskets or o-rings for the drain plugs, then lube them up real good and see if that helps.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  19. Back To Top    #19

    Join Date
    Dec 2015
    Location
    Chino/CA
    Posts
    201

    Re: Pump not getting full

    My pool has 1 floor drain and 1 main skimmer and 2 return lines.

    My spa has 1 floor drain, about 6-8 wall jets and holes on the floor for air bubbles.
    Chris B.

    New house w/ 28 y/o I.G. 15k gal. pool/spa, Plaster, Hayward DE-480S Micro Clear Filter, Pentair Whisperflo wfe-4, 1HP (Main Pump), Hayward SP2815x20 (Pump for spa jets), Versa Pool Heater, Hayward Pool Vac Ultra, TF-100 Kit

  20. Back To Top    #20
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,486

    Re: Pump not getting full

    Both pumps more than likely pull from the same floor drain. That is the way mine is setup. There are actually two sets of pipes all the way to the drain for each pump. If you drain the spa and remove the cover, you will likely see two pipes under the cover. If not, they may have split the pipe underground. But the valve should never need to placed in-between. The jet pump is getting water otherwise it would never prime.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •